Air Unit unresponsive + noise sound


I was tweaking my quad trough GCS when mavlink connection was suddenly lost.
Ground Unit couldn’t see Air Unit anymore. Tried powering off/on again, nothing.
Air Unit is now totally unresponsive, but seems it’s a singer now…:slight_smile:
It emmitts an odd noise since this happend.
Video here:

Air Unit is powered with 11v bec.
It never flied yet, I still have some setup to do.

Even if it’s faulty, any idea what could happened ? I’m a bit worried now it happen again with another unit in flight.

Was the unit overheated?
Can you check if any cable is short circuited?
Also, can it be recognized when connecting to computer?

Hi Calvin,

Unit was a bit hot but nothing anormal it seems
The noise I get here looks like a power issue ( blown capacitor on the regulator perhaps? )

I have triple checked my wiring with a multimeter everything is correct ( it was working correctly before earing this noise and communication shutdown after 5mn. )

I haven’t tried plugging it on usb yet. Will do.

So I’ve plugued it on USB ( & powered by 11v bec ) , It mounts the SD drive and then unmount it 1 sec later, then mount it again, etc.
Still the strange singing sound.

Can you try to update the firmware again on the air unit? Just in case it was software problem.
If it was hardware problem, the updater should be not able to detect the unit at all.

So I could flash the air unit using the software
Then after reboot, it still stuck in mounting/unmounting the sdcard in loop.

If I try to pair again, led 2 doesn’t blink when reset is kept pressed.
Signal strength on ground stay at -141dbm. Still no link anymore.

Seems the RF stage is dead. Is there a way to log in console in the air unit and confirm that from some log?

You may following this guide to generate a bug report

I’ll do, but it will only give you ground unit debugging.
Don’t the sound from the video on first post give us clear sign off a hardware malfunction?

In this case you may contact your local distributor for RMA