"Cannot register your device" message when updating


I always get “Cannot regisgter your device” when updating Herelink.
I got the 16 digit software activation key from my reseller and selected EU in region selector, because I am in Europe.
Also I connected it to 5GHz wifi and looks to be connected.

This message appears 30 seconds after pressing REGISTER button.

Any suggestion?



Please try a different internet connection.

This is usually related to not being able to connect to the server.

Thanks! I share connection of my phone and now it is downloading the update.

1 Like

I have already make the first (April update) with the key that my seller gave me but now I can’t update to the latest (May update) because again asked me for key and when I import it, it is say that I cant register this device. I have tried 2 different connections with no luck.

Just to confirm you are using the same key ?

This is usually internet connection related this issue.

Yes I am using the same key. I tried in 2 different internet connections.

@sidbh anything you can do on this one,

Hi @Stelios Were you able to do the update? ie your Key got approved? I have too tried on different connections and changing the IPs but no luck…