Cube Black and SF11/c

(Russell Stutzman) #1

Arducopter 4 RC1, Mission Planner 1.3.7236.10299. I’ve wired up my SF11/c to the cube black and can get it working using I2C on the gps2 port. I set RNGFND_TYPE1 to 7 and address 102. That seems to be the only way it works. If I move the settings to any other Range Finder, I’ve tried 2, 3, and 4, I continue to get readings in Mission Planners Status window under sonar but Mission Planner reports range finder x is not found.

I’ve tried using serial 4 on the gps2 port but couldn’t get any readings after double checking the settings on both the sf11/c and the cube’s serial4.

My question is.why doesn’t this work with other range finder ports. Am I missing some setting somewhere?

#2

If this is a change of behaviour from 3.6.11 to 4.0, then I would recommend discussing this on the 4.0 rc1 thread on the Ardupilot discussion forum

(Russell Stutzman) #3

I’ve been trying to get the hereflow and the sf11/C both working together so I’ve been on version 4 pre-release all along with this.

Thank you for the reply. I will ask over on the ardupilot forum.

1 Like