Cube black issues

(Aaron Gruenberg) #1

So I’m having 2 new issues, with an old controller. I’ve been building my monster kinda slowly (I’m a broke !@# ski lift mechanic.) Trying to run a Gremsy t3 v2 via sbus out from a standard carrier board. Serial 5 is reading full sbus, but only with a servo lead barely touching the pins. If you push it onto the pins, all signal is lost. This is the second bird this cube has been on, with hours and hours of successful, well tuned flight. The maiden on my heavy lift octa, was scary.

Tried with the servo rail powered via a Mauch power system Hybrid bec 5v, and unpowered. Testing with a ISDT BG-8s, and the gimbal software. Symptoms are consistant. So I just ran a sbus splitter from my X8r. I can control my gimbal, but my flight controller can’t.

My second issue is I randomly can’t flash firmware now. At first the cube was registering as an Omnibus f4. Windows 10 pro, so not my first driver issue by far… finally got it registering as an STMicro virtual com port. But on firmware flash, the board doesn’t reset, and reconnect. No response from board error. Tried 3 different computers, with different windows versions. Same issue. Yet, I can connect, and do anything else.

Honestly, my gen 1 pixhawk clone is far more reliable thus far. Is my cube dead?

#2

For it to show as another board type… something has caused that…
where did you get this cube?

(Aaron Gruenberg) #3

I got my cube from either robotshop, or air supply aerial. Had it for probably 18 months. Got it to flash on windows vista. Still no consistant sbus out though.

#4

Vista? Really? Please use windows 10 or Linux…

(Aaron Gruenberg) #5

I would love to use my windows 10 computer. But it’s not connecting right. My old vista computer is all that will talk to the cube. My pixhawk Clone connects fine though.

(Aaron Gruenberg) #6

An advice for the sbus out? Seems like the signal pin has a bad connection. Any pressure, and you lose signal. So it’s basically useless.

(curt carroll) #7

try mav link driver 6.7.6. driver . with windows 10.

(Aaron Gruenberg) #8

I’ve tried the silabs drivers numerous times. windows vista is the only OS i have gotten to connect, and flash right. i can now load parameters, but it will not save any changes made. ive lost all my contracts, and my company is now in jeopardy. I’m seriously debating removing my cube entirely. I need consistency in my equipment. i cant say i can trust this fc anymore.

#9

you are connecting via a clone SIK radio? and you are blaming the flight controller?

contact your supplier and ask for an RMA, happy to take it back.

If your s.Bus out cable is damaged, replace the cable.

#10

what power are you using for S.Bus out? you do know that you need to power the rail for this?

(Aaron Gruenberg) #11

No, connection is a direct usb cable. I’ve tried several functional leads for sbus out. I’ve tried with the servo rail powered, via a mauch electronics 5v out. Power isn’t the issue. It’s bad signal pins in the board. I’ve been flying pixhawk flight controllers in multiple airframes for years. Side note, you can’t flash firmware over a sik radio connection anyway, so why would I try that?

(Aaron Gruenberg) #12

The only clone I’ve talked about, is a gen 1 pixhawk clone.

After flashing firmware on a much older computer, I can connect and change parameters again. At this point, all I need is solid sbus out, so I can have my fc control my gimbal.

#13

If your connector is broken, RMA it

(Aaron Gruenberg) #14

As I have stated. It loses connection, it is in fact not broken, just not functioning. Maybe actually read the posts, and address the issues addressed, instead of assuming things. As a Chemical, biological, radiological, and nuclear ops specialist, I am in fact, not an idiot. I have tested your companies hardware, and found a layes in your PCB that is has a bad trace. That, is a failed product, and NOT “broken”.

Please actually address the issue.
Take responsibility for your product.

Out.

#15

how many times do I need to tell you to RMA it?

do you need a written invitation from the queen?

not functioning IS BROKEN

REPLACE THE DAMN THING AT OUR COST!!!

#16

company name: Paladin UAV

Please make up your mind as to what you are? If you would like to constructively engage in the community, that would be great! Each of my comments back to you was an attempt to assist you, I have posted three times now to RMA it. who is your distributor?

If you are from Paladin as you claim, then why the “i’m a broke ski lift mechanic” story?

me taking responsibility… RMA the equipment…

Where did you get the cube?

the SIK comment… two things, that was a cross post… and yes you can update firmware via a serial connection if you have all day…

  • out…
#17

Our staff helping you over on the ardupilot forums…

gimble tips…

more of the team helping you…

if you want advanced features, you must use the latest firmware.

So, if you would like our community to assist you further, feel free to ask questions, contact your reseller for an RMA, but be nice about it.

(Aaron Gruenberg) #18

My deepest apppgiea I got blown the hell up in combat, and was medically retired. So I am in fact, still a CBRN, however, due to a military discharge, I’m not active military. So I became a ski lift mechanic, but my destroyed body, I couldn’t hack it. So I opened Paladin UAV almost 2 months ago. Also, all firmware across the board, is current as of thursday the 29th. I’ll get screenshots, and a video of the issue when I return home.

Incredible customer service.

#19

Thank you for your service! It is very much appreciated.

Unfortunately other than getting the thing replaced, I’m not sure what other advice to give you.

If you get the exact same issue after replacing the unit, then we can look for software issues with S.Bus

Or, you could try Mavlink serial on the Gremsy

I believe you need a firmware update on the Gremsy for that to work

(Aaron Gruenberg) #20

All firmware is current. Working with gremsy to see if control over mavlink is even possible. Thus far, mavlink just locks the gimbal up. SBUS is the only control responding. How do we get this RMA ball rolling?