Cube black partially responsive

(Andrew Roberts) #1

Recently bought a Cube Black from JDrones. When I power it up to flash the firmware the LED blinks orange, the correct tones sound, the LED goes solid then it turns itself off and the computer sounds that the USB has disconnected. Needless to say I haven’t managed to flash the firmware (using MissionPlanner though have tried the other culprits with no luck). This happens whether I used a USB as the power source or a battery.

Ideas welcomed.

#2

have You updated your mission planner to latest via the msi? Have you loaded the driver pack via the msi?

#3

https://discuss.cubepilot.org/t/windows-drivers-for-cubes-direct-install

(Andrew Roberts) #4

Yes using all the latest software. The MP sees the cube but the cube turns itself off before it can be found at the “scanning comports” stage. Yes I have disconnected the usb and replugged it in. I can hear the usb disconnecting and the led on th cube goes off. Is there any way to reset the cube?

(curt carroll) #5

Once the cube boots the led lights go off. So the cube is still on just not recognized by your machine.

(Andrew Roberts) #6

But there is the distinctive USB disconnect sound. When plugged in the USB is assigned to COM11 in the Device Manager as ProfCNC CUBE F4 FMU(COM11) so it does see it. When trying to install the firmware the popup shows the platform as CubeBlack and the Bootloader as CubeBlack-BL.

(Andrew Roberts) #7

Just out of curiosity managed to connect MavLink and see all the parameters. Repeated trying to download f/ware and got message that it’s already there??! Very odd. Will see if the rest of the setup works…

(curt carroll) #8

It sounds to me like your USB driver is not working once the cube boots up.
You may want to reload MP from the MSI to update drivers.

1 Like
(Andrew Roberts) #9

I am using the most recent version of MP. Worked fine flashing a new PixFalcon mini. Curiosly I have exactly the same problem flashing an older (about a year ago) Cube with the latest firmware. Scanning comports times out with “no response from board”. I have no idea whether it has actually updated the f/ware or not.

(Andrew Roberts) #10

Tried another laptop running Windows 10. Works fine. No explanation as to why this would be.

(curt carroll) #11

I had my fair share of Windows 7 and 10 issues, especially with the MP drivers. Version matters, 7 (was) great!, S stands for suks, likewise 10 Pro stands for Provide your own drivers. These issues are so machine specific it is very hard for anyone else to help.

(Robert Gray) #12

Using Windows 10 Pro build 1809 and installing MP (I mostly use beta software) update to latest with all its drivers then GQC (mostly beta as well to have the latest software for R&D purposes) on top and all is working fine here. However, if you have older versions preinstalled (MP, GQC, etc.) and a mixture of drivers installed along then that may cause all sorts of issues when you install a newer version on top.

To flash firmware and do final testing, I use a fairly clean but much older laptop running Windows 10 Pro (1809 in my case) with MP and GQC installed.

My dev-env is way messier due to various toolchains and R&D tools where I regularly experience the odd issue with drivers due frequent updates that are messing things up at times. Cleaning our old builds and drivers helps to keep things running, the alternative is to install a fresh OS every now and then.