Cube black was burned

my experiences 3 times cube black was burned. first time, I did rewrite bootloader to the carrier board firmware, it was worked. recently my 2 others cube black was burned again. tried to rewrite bootloader to carrier board again, but it does not work.
finally, I found it is cube problem.
but it works for official rover 4.0.0, does not work for my firmware on this burned cube black.
my firmware is OK, can be run another cube black and other brand hardware.

I use Mauch power modul.
my question is,

  1. what is the reason, how to fix it. the reason may be I turn on/off to frequency.
  2. how to avoid this happen again, because I can’t guarantee enduser frequently turn on/off machine

I fixed this issue.

  1. rewrite bootloader
  2. install official firmware
  3. install my parameter
  4. update my firmware

if I skip step 3), it makes issue.


When you say burned, do you mean its softwarely broken or physically broken?
From my understanding, if they are physically broken, you won’t be able to fix it. So I assume you corrupted the bootloader.

  1. install official firmware
  2. install my parameter
  3. update my firmware

I guess the parameter messes up something. You may try to upload different firmware so that they have completely different set of parameters. (eg: install official plane > install your custom copter)

It is not physical burned. I can recover it using ST32 utility.
After rewrite bootloader, install official firmware, it works, then I tried to reset default parameters or install my parameters list first, then I can update my customized firmware, and it works.

If I just update my firmware after official firmware install without parameters changes, the Cube can’t start up.

My Cube is connected AUX, i2c, can etc device.
I want to know what is reason occurred bootloader frequently burnout.
Any advise, very appreciated.

Is there any great changes in your custom firmware? like structural change? Or maybe there is parameter conflict?

How did you upload your custom firmware? Did you use GCS or command line from the repo?