Cube not booting up

Hello everyone,
I have been using cube orange on PX4 since long and its worked fine but after a crash yesterday the cube is not booting up when connected to battrey via power module.
The cube and everything works fine when connected to USB and mission planner.
The power module is also working fine when tried on another cube orange.
Please help me

Can you try to use POWER2 port?
If it also not working, can you try to swap the carrier board?

No i dont have another carrier board to swap.
Is there any other way??

So you have another Cube Orange to swap but not carrier board, am I correct?
Then I guess you have tried to swap a different Cube on the same carrier board?
If so, you should have proven the problem come from the Cube itself and not on the carrier board.

But what happen if you use POWER2? Does it work?

It doesn’t work on power 2 also.
Regarding checking on another cube I checked my power module on my friends cube orange just to test if my power module is working or not I am not in a position to ask him to swap our carrier board

Can you open the carrier board housing, and probe the following pins on the PSM?

Probe the IN_5V_A and IN_5V_B when connecting power from POWER1 and POWER2 respectively. Then probe IN_5V_USB when powering from USB.

Also probe the voltage from 5V_OK which different power source.