Current data on Hex Power module

Hello all, I’m using hex power module(comes with pixhawk cube.) and other power module on online shop.

I experienced current data imbalance of two power module.(like above picture)

I guess power module on online shop works well because its current data is about 12 Amps.
but hex power module reads about 2~3 amps which is totally unsense.
I’m using two parrallell lipo battery(2 x 6S 2600mah 130C)

I looked into battery monitor setting and found my power module is set to preset “Cube HV Power module”, so it seems that my settings are not problem.

Seems like you might have it all wired incorrectly.
It wouldnt be advised to run two current sensors in series (or parallel).
Maybe post a diagram or photos of what you have now, and a param file or .bin log

my battery configuration is “3” in this link :

you said it would be advised to run two current sensors in parrallel, but here people saying it is okay:

I see, 1 sensor per batteryis good. One must be calibrated incorrectly. What is that 2nd sensor?
And your param file…


red circled point is where 2 power modules is

red circled point is parrallel connection point on tbs discovery frame

Thank you for your very fast reply.

I didn’t expect answers very fast like this, thank you

this is my parameter file.

“battery 0” is hex power module, and “battery 1” is aliexpress power module.

and there is no “battery 2” in my log.
params for forum 20220924.zip (5.1 KB)

as I mentioned at my first article,

my battery sensor for “battery0” is set to preset “Cube HV Power module” and it seems not to be calibratable…

https://drive.google.com/file/d/1YcB3NrXO5FUG9KDd5UHqapZCwsiBWPpC/view?usp=sharing

my log file is too big so I upload by google drive link.

this is my 15 mins flight log

Your Batt 0 params look good for a Cube power brick.
The voltage readings of both power bricks match very closely so that’s good.

I think you need to set BATT2_AMP_PERVLT to 17 for a start, like a an old 3DR (standard) power brick.
You can change it in Full Parameter Tree easily. Reboot to take effect - for any battery related settings actually.
Both should be providing about the same amount of current, within reason.

Here’s how to adjust you’re Amps Per Volt
You would do this on a per battery/current sensor basis.
Like charge both batteries, perform tests below for one battery and current sensor - always charging both batteries equally, but charge the battery under test first and record it’s maHr charged.

  • Plug in a fresh battery and do a hover flight for 5 minutes or until you’ve used a significant amount of battery capacity
  • Immediately unplug the battery and charge it, note how many mah’s it took to charge. Let’s say that was 1,500 mah
  • Download your log and look at maximum CurrTot. Let’s say it was 1,300 mah
  • Get your existing BATT_AMP_PERVOLT setting from Mission Planner
  • NEW_AMPS_PER_VOLT = OLD_AMPS_PER_VOLT * CHARGED_MAH / LOGGED_MAH
    With my example numbers, you’d get
    NEW_AMPS_PER_VOLT = 17 * 1,500 / 1,300 = 19.61
  • Set the new value in the BATT_AMP_PERVOLT parameter and save to your copter
  • Fly to check, repeat until you’re happy the new value gives consistent readings

EDIT: You could just run everything through the Hex/Cube power brick. If you want the 2nd power brick for redundancy you could just hook it up as a BEC to supply regulated 5v to Power2 like you have now - but just not passing any current.

Thank you for your answer. it is very understanding and detailed explanation. it is very helpful.

but there is one point that I couldn’t understand.

if cube power brick’s setting is good, it means that my quad using 3 Ampheres in hovering.
if so, my quad’s flight time should be at least more than 40 minutes.

but my quad’s flight time is 15 mins. I guess 17 ampheres is reasonable current that my quads consumes.

batt0 is cube power brick and it reads 2~3 ampheres so I guess there is something problem on cube power brick…

anyway, after charging my battery, I will try as you said. thank you.

As for the rest of the tuning, vibrations are bad and should be addressed before you do much more. Be prepared to use Stabilise mode in case this tries to keep climbing.

Set these before the next test flight, do some hovering and just a few gentle pitch and roll movements, let’s see that .bin log file. Don’t try Autotune yet.
INS_LOG_BAT_MASK,7
INS_LOG_BAT_OPT,0
INS_HNTCH_ENABLE,1 ← set this then refresh params to see the rest
INS_HNTCH_MODE,1
INS_HNTCH_REF,0.36
INS_HNTCH_FREQ,80
INS_HNTCH_BW,40
INS_HNTCH_ATT,40

Thank you for your recoomendation on my log…

vibration was caused by bad propeller(Im using 3-leaf propeller, and its hole was not in center) and I changed it to good one several minutes ago.

that bad propeller even caused yaw imbalance in my quads. log auto analysis couldn’t catch the yaw imbalance but I catched problem by reading logs.

I will change the parameter as you said and look into the result. very helpful answer and thank you.

I’m intense at every flight and are ready to change to stabilize mode.

I experienced keep climbing before several years ago(it was apm quad, not pixhawk) I’m usually making heavy quad than usual quad. I guess it is reason of vibration and shooting upside.

thank you for your recommendations.

this is my second flight log for your reference.

I changed 1 bad prop but it seems not to help reducing yaw imbalance…

it seems that vibration still exist with the log. with naked eye I can’t see the vibration(even little. it looks very clean. no vibration on the power module or antenna pole or electric small lines.) but I guess this motor and batteries are too big for 450 quads

https://drive.google.com/file/d/1JfHRpXlHaYAvdXlGm1cGllZW-9OCNpet/view?usp=sharing

this is params on 2nd flight.

params for forum 2 20220924.zip (5.2 KB)

it turns out that one of my motor screw hole was damaged and screw cannot hold to hole.

I guess this was the reason of yaw imbalance and vibration.

I will buy new motor and after the motor arrive I will fly my quad again.

For a Hex/Cube power brick the correct BATT_AMP_PERVLT is definitely 39.877 or very close to that.
If you are not getting the correct current reading, then it’s not wired up correctly.

And I would be surprised if your quad is drawing over 17amps to hover with a 6S battery.
I’ve got a bigger quad-X8 (Octoquad) sitting here , that’s 8 motors and 13 inch props, with a 6S 12Ahr battery and it does 22amps at hover. So either your second current sensor is very wrong, or the wiring is not properly done as per that “3” diagram.

On the plus side, the Harmonic Notch Filter settings are good. You’ll have to fix the vibrations as planned and do another test flight.
I think you could use these PIDs
ATC_ANG_RLL_P,6.0
ATC_ANG_PIT_P,6.0
ATC_RAT_RLL_P,0.12
ATC_RAT_RLL_I,0.12
ATC_RAT_RLL_D,0.0075
ATC_RAT_PIT_P,0.12
ATC_RAT_PIT_I,0.12
ATC_RAT_PIT_D,0.0075
Just take off and hover for only a minute or less then land and check motor temperature, if it’s OK you can fly again and just do some gentle movements - let’s see that log.
If that log is OK, vibes are good and HNOTCH is working you’ll be able to set:
INS_LOG_BAT_OPT,2
and probably run Autotune.

  1. as per my 2nd flight log(this log is recorded after modifying BATT_AMP_PERVLT)
    average consumption is 5A each.(total 10A)
    so you don’t have to be suprised. my quad draws 10A. and it is very heavy because I’m planning to use it on delivery device experiment.(don’t worry about it because safety precautions are fully understood and implemented.)
    10A is reasonable amount that my quad consumes, so I believe appropriate BATT_AMP_PERVLT value for cube power brick is “120.17”
    is it something wrong with my cube brick?
    I bought it from trusty reseller and have certificate(?) in the box.

  2. I wired it up correctly. I know what is parallel connection and I assembled many quad or octo from several years ago.
    if something problem on connection, the quad should burn or cannot be charged. but my copter flew more than 10 times and recharged well without any accident. the power module is on each battery.
    I don’t know how electric wire connected inside tbs discovery frame, so it can be problem. but I believe it is simple wiring. I checked electric connection with multimeter. TBS discovery frame have inside connection between ESC part and Power part. so I connect my parallel 2 battery to frame’s power part .

  3. if BATT_AMP_PERVLT : “39.877” is correct, it means that quad consumes 3A each battery, so total consumption would be 6A. with that consumption, my quad can fly about 1 hour because I’m using 2 * 6S 2600 mAh battery.
    I think something wrong here, but I can’t figure out what is the problem.
    I dig into old log(about a month ago) and all the logs was same. “batt0” consumed 3.38A(min 0A max 5.93A) which is totally unsense.

  4. for your reference, “batt0”(cube power brick) is connected to cube orange hardware pin “POWER1” “batt1”(aliexpress power brick) is connected to cube orange hardware pin “POWER2”

  5. as my motor will be changed soon, I would like to question that if I can turn off Harmonic Notch filter.
    If vibration is in acceptable range, could I turn off it?
    if it is necessary for heavy quad like my one, I will turn it on. I guess this can be marvel and new things that I couldn’t imagined before,
    but if it is just for temporary vibration I want to eliminate vibration rather than using software filter because I’m unsure about new function of this firmware.
    and thank you for PID value. I will use it for my next flight and post the flight log. I once checked motor temperature and it was okay. I will take care about it after changing PID also.

  6. if I find answer I will post the information here.
    my motor will arrive next week so I will upload next flight log next week.
    I really thank you for your reply.

my cube power brick looks like this




Leave the harmonic notch filter settings in place.
You need to calibrate that second current sensor properly.
At least the voltages are all reading correctly.