Drone Crashed, cube not responding to radio signal

I was flying my new drone, after takeoff, the drone was drifting, I activated RTL mode after which drifting doesn’t stop then I tried to do pitch and roll using radio but it did not respond to any signal and hit the tree.
Guidance required, log attached below for reference.

today’s log.BIN (564 KB)

hi
I had the same problem a few days ago (last flight, then bench tests only)
After doing a mixed route at an altitude of about 5m, I saw a significant loss of altitude until the APR touched the ground at a minimum speed but at that moment I had no control. I have repeatedly tried to invoke the APR at altitude but it did not respond to any command.

As soon as I landed (with great luck and without chrash) I brought the APR back to the take-off place by hand and tried another flight without switching off and on again at my own risk and I wanted the problem to repeat itself. In fact, in this second flight I took off and once at about 5 meters it no longer managed the throttle

I am very very very worried

your gps signal was bad, and according to google maps you where surrounded by very large buildings
you tried guided mode and rtl, both realy on gps. you should not be flying relying on gps in this scenario.


this shows the EKF was not happy with the gps data it was getting.

we need logs, else we cant help

and as for any RC, the log shows rc was working fine, however the copter was in RTL mode, and the sticks dont do anything in this case, there should have been a mode change first to a manual control mode.

Ok. Got the gps issue, but in RTL mode previously I have used pitch, yaw and roll movement

I am more worried about the radio response as it never happened with me, many times I have adjusted the position while landing drone in RTL mode but today it just didn’t respond

most likely because of the bad gps, if the gps is saying it moving one way, and your stick says the other, they cancel out.

If it happens in stabilise mode then what could be the issue because 3 day back same thing happened, it just didn’t response after which I have force disarm it, sorry I am worried that’s why I am shooting queries

I apologize and I would not like to take advantage of the post already open but I believe that the question is common so as requested by Michael I send the flight log, with the clarification that during the two landings, I acted on the thrust to the maximum but the actions taken are not highlighted at that moment … I assure you that when the descending parabola started until it touched the ground (first run), I gave the gas without any effect. In the second run, during the short hovering phase at 5m altitude, I gave the gas but without effect. Also in this case I do not find my action highlighted

thank you for your immense and precious work

Hey @Mohit953
You had same issue before regarding copter not holding position well. From the video I had mentioned not fly close to buildings and expect GPS modes to handle things well.

If you cant arm in LOITER mode then you do not have good enough GPS positioning for RTL or any other GPS-reliant mode. Use ALTHOLD.

im not sure im understanding the issue

the rc input shows there was no real input to make it go higher, only mid stick and lower.

Thanks Michael for taking a look at the log … correct !! … practically after take off and a moment of hovering, as soon as I make an advance or any maneuver, it loses altitude to the ground and any action on the sticks is null

A little while ago I made another flight and unfortunately I suffered a couple of abnormal landings even if light … (in the log there are two flights in the same run of batteries without disconnecting them)

So in short, after take off, I did a hovering and after a few seconds it no longer responded on the vertical going down to an altitude insensitive to the sticks … both for the first and for the second flight

I attach the log

NOTE: the conditions are: Primary battery only (no second battery), voltage control only (no Ampere), internal barometers + external barometer enabled on Here2 (in fact the # 3 barometer always has a peak but I don’t know if it is the external one), barometer external on Here2 with TCal = 1 for temp compensation

IMPORTANT: a further note is that the aircraft has become quite heavy over time (7.5 Kg) and I realize that it is underpowered as engines (No. 4 Tarot 5008 / 320kW). So I ask if maybe the FC determines an excessive weight and forces a sort of self-labeling (but without it being highlighted in the log).
However the take-off is around 68/70% of the throttle … I piloted APR much more border line :slight_smile:

Your motors are definitely being commanded to maximum, there’s no way to gain or maintain altitude while maintaining stability.
This is bad:
MOT_BAT_VOLT_MAX,4.400000095367432
MOT_BAT_VOLT_MIN,3.5
They should be:
MOT_BAT_VOLT_MAX,25.2
MOT_BAT_VOLT_MIN,19.8
But it wont fix the physical issue of not enough thrust.

I would definitely set up the current monitoring, and use this helper spreadsheet to check you other settings.