Flasher_linux fails, libusb_error_timeout

run command on ubuntu…
sudo ./flasher_linux
this is the response.
Expected to flash airunit.

Looking for Device..
Found Unit Type:  airunit

Downloading required package...
Latest airunit release: AAU01211129
Downloading Latest Release from  https://herelinkfw.cubepilot.org/airunit-AAU01211129.tar.gz
airunit-AAU01211129.tar.gz: 100%|███████████▉| 215M/215M [03:25<00:00, 1.10MB/s]
Successfully download package
Extracting package...
100%|███████████████████████████████████████████| 19/19 [00:04<00:00,  4.52it/s]
Successfully extracted package
Flashing Unit...
Flashing partition: 100%|██████████████████████| 223/223 [00:00<00:00, 3.10MB/s]
Flashing persist: 100%|████████████████████| 4.30M/4.30M [00:00<00:00, 58.2MB/s]
Flashing oem: 100%|████████████████████████| 4.56M/4.56M [00:00<00:00, 59.3MB/s]
Flashing boot: 100%|███████████████████████| 23.3M/23.3M [00:00<00:00, 47.2MB/s]
Splitting Sparse Partition system.img @ /tmp/tmppun8qgpa
Flashing system 1/10: 100%|████████████████| 56.0M/56.0M [00:01<00:00, 45.2MB/s]
Flashing system 2/10:  72%|███████████▌    | 40.0M/55.5M [00:01<00:00, 38.9MB/s]Traceback (most recent call last):
  File "site-packages/adb-1.3.0-py3.8.egg/adb/common.py", line 175, in BulkWrite
  File "site-packages/libusb1-1.7.1-py3.8.egg/usb1/__init__.py", line 1546, in bulkWrite
  File "site-packages/libusb1-1.7.1-py3.8.egg/usb1/__init__.py", line 1517, in _bulkTransfer
  File "site-packages/libusb1-1.7.1-py3.8.egg/usb1/__init__.py", line 133, in mayRaiseUSBError
  File "site-packages/libusb1-1.7.1-py3.8.egg/usb1/__init__.py", line 125, in raiseUSBError
usb1.USBErrorTimeout: LIBUSB_ERROR_TIMEOUT [-7]

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "flasher.py", line 278, in <module>
  File "flasher.py", line 164, in flash_all
  File "flasher.py", line 220, in flash_img
  File "site-packages/adb-1.3.0-py3.8.egg/adb/fastboot.py", line 289, in FlashFromFile
  File "site-packages/adb-1.3.0-py3.8.egg/adb/fastboot.py", line 325, in Download
  File "site-packages/adb-1.3.0-py3.8.egg/adb/fastboot.py", line 137, in HandleDataSending
  File "site-packages/adb-1.3.0-py3.8.egg/adb/fastboot.py", line 197, in _Write
  File "site-packages/adb-1.3.0-py3.8.egg/adb/common.py", line 178, in BulkWrite
adb.usb_exceptions.WriteFailedError: Could not send data to first (timeout 10000ms): LIBUSB_ERROR_TIMEOUT [-7]
[70546] Failed to execute script flasher

What can we do to fix airunit?

my first guess is bad usb cable. replace the cable and try again

regarding recovery
hold in the pairing button, and power up the unit for about 10 seconds

Thank you very much! This is insanely helpful advice!

The usb cable doesn’t appear to be issue, if I use it on mac the flashing process works fine… it’s only when using on my ubuntu laptop that this error shows up. I tried it a second time after successfully doing on mac and it produced the same error.

Regarding recovery… have tried the method but the led2 light doesn’t show afterwards.

when using the hold down pair option, no leds will light