Here+ RTK with Pixhack - no status LEDs

I have a brand new Here+ connected to the GPS/SAFETY port on the CUAV Pixhack V5+, but am not getting any status indicator LEDs. The GPS operates successfully, and the safety switch and safety switch LED work. However, the status LEDs on the sides of the Here+ do not come on. They flash white briefly on power up and power down, but that’s it. Firmware is v1.3.

Has anyone encountered this before, or have some troubleshooting tips?

PS: I had to switch the Here+ 8-pin connector out with a 10-pin connector to make it work with the CUAV V5+. I used the Here+ pinout documentation and CUAV V5+ manual pinout diagram to do so. My pin configuration is:

Black (GND)
Empty (Former BUZZER)
Empty (Former SAFE_VCC)
Orange (SDA)
Yellow (SCL)
Green (TX)
Blue (RX)
Purple (5V)

Have you tried switching tx and RX ?

I solved the issue after determining that the compass was also not working, and therefore narrowed the problem down to the I2C bus.

Turns out it is related to a known hardware flaw in the CUAV V5+ design:

The Here+ I2C signal was essentially being disabled by the autopilot’s POWER2 module. The solution was to unplug the second power supply from POWER2.

glad you found it… maybe upgrade your system to a cube?