Here2 and ublox existing together?

Looking for some GPS help please

Orange CUBE (FW updated last week)
here2 GPS on CAN1
Holybro Pixhawk 2nd GPS (uBlox) on GPS2
Mision Planner, also updated last week

There is no data on ‘sat2’
I’ve double checked my settings for both ‘sat’ and ‘sat2’ and they all look correct based on what I can gleen from the Arducopter/Mission Planner documentation

Am I doing something stupid?
I’m sure this combination of GPS units should co-exist together.
The annoying thing is a week or so ago I had data for ‘sat’ and ‘sat2’, also ‘hdop’ and ‘hdop2’, but the satelite count was the same and considering this was indoors workshop, ‘sat2’ performance would be expected to be lower than ‘sat’
But not anymore :frowning:


All help gratefully recieved
Steve :slightly_smiling_face:

Unless the other GPS is broken, no reason why not.

But my question would be why? Put two matching GPS’s together, or blending will always be worse than just using one Here.

Hi Philip,
I’ve tried two M8N GPS’s it’s the same with both.
Does MP set the baud rates or do I need to / can do that manually?

Reason is redundancy, I expect the here2 to have better signal and will set copter to use ‘best’
M8N is there just in case here2 falls over.
I thought this arrangement was common practise, is this not so these days?

Thanks you
Steve :slightly_smiling_face:

I have tried Here2 on CAN and UBLOX M8N on serial and only can shows up. Swap can back to Serial and both work fine

You can use it that way, but switchover is harsh

Blend is much better, but best when hardware is matched

… and what is matched hardware?
are you saying here2 on CAN and M8N on serial is not supported?


He means 2×HERE2 instead of generic M8N and Here2 combination.

1 Like


Hi Phil, Michael
Still struggling with this but I’m getting the picture that ‘here2’ on CAN and an M8N on serial will NOT work and is not supported. Is this lack of hardware support or firmware code? and are there plans to cover this in future Ardupilot or MP revisions?

So does this mean that I have to fit GPS1 serial cable to the ‘here2’, and then with Holybro M8N on GPS2 it will read both GPS units?

Steve :slightly_smiling_face:

A here 2 on serial and a Here2 on CAN will work perfectly fine.

When you say a generic M8N, I have no way of telling you if it will work.

Unfortunately many many “generic M8N” modules are simply fakes, or built to such low standards that it’s just not worth using.

Assuming it’s not junk, it will work fine.

Hi Phil

This the M8N, purchased from you recently, it is sold as a ‘second’ GPS so I assumed I’d be OK with it.
I appreciate it says Pixhawk4, the connector is same for CUBE and I checked the pinouts and have also checked it works on U-center, Interestingly it was running at the same baud rate as in the MP parameters (38 = 38,400) so it looks like the autoconfigure works

What’s my best option?
Are here2’s ultra relaible and I don’t need a second GPS for redundancy?

Thank you

Single Here2 is pretty reliable. But if you are using it on huge copter with expensive payload, it’s better to add one more Here2. Usually it’s not Here2 which will have reliability problem. Sometimes during transportation, connectors might come loose if it’s exposed or something bad mechanical might happen. If you do pre-check of all this before flight, a single Here2 is good enough.

1 Like

Well, it seems to be an init problem.

Steps to repro :
Connect a here2 to CAN1 and configure GPS_TYPE 9.
Connect a generic Ublox (for example the Holybro Pixhawk4 secondary GPS) to GPS2 port and configure GPS2_TYPE to 2
Reboot > Only GPS1 detected.

Set GPS_TYPE to 0 and reboot > GPS2 detected correctly. Now set GPS_TYPE to 9, Here2 detected on the fly and both GPS works. But after reboot, only the Here2 is detected and GPS2 not seen.

Solution, if your serial GPS is connected to the GPS2 port (Serial4) then SERIAL3_PROTOCOL must be other than 5. Or you have to connect the serial GPS to the GPS port (Serial3)

You are a genius :clap:

then SERIAL3_PROTOCOL must be other than 5.
It worked for me :+1:

Thank you
Steve :slightly_smiling_face:


inside a garage, hdop’s probably better outside

Interesting this must be a bug in Ardu, I think I fell across this as well a while back but did not manage to replicate.

Have you reported it on Ardupilot forum or in Git ?

I’m plan to fix it and do a pull request…