Herelink Channels 1,2,4 not transmiting to the Cube

I have the herelink calibrated and the cube can read channels 3 and 5 on the RC calibration screen in mission planner. No matter what I try I can not get channels 1,2 or 4 to be picked up. I have tried Sbus calibration on the herelink, mission planner radio calibration, changing mavlink protocol in mission planner. The herelink shows that the stick inputs for those channels and sbus output are accurate but the cube just cant read it. Is there anything else I can try?

1 Like

do you have slave mode enabled? or have you assigned to the wrong s.Bus cable?

can you post a video of the Settings joystick page, and also the mission planner joystic calibration page

hi check your airunit and herelink version in herelink settings and if you can check your local and latest firmware available i had the same issue it isnt solved but i was trying with cuav x7 and the same setup works with pixhawk orange


Here is a video of what is happening.

I just loaded latest firmware again set up the configuration in MP. It worked for a few minutes and after i rebooted the system due to arranging the compass priority it started having the same issue where only chancel 3 and 5 will come through. I am also now getting a failsafe no rc reciever.


Here is a video of a fresh install, configured the gps and herelink…did the rc calibration…worked fine…tried to arm non zero throttle…went to rc calibration…flipped the throttle channel and then lost the input from 3 channels…

Yeah, that seems to be the issue. When i click reverse on the throttle chanel it removes the other chanels.

Ty6411. What was the solution - Im having the same problem.
I reversed the direction of throttle and have lost channel 1, 2 and 4

hi i have same problem. i want to Check your video but is not available. can you help me plz

hi i have same problem. i want to Check your video but is not available. can you help me plz