Herelink Controller Unable to be Registered After Firmware Update

I recently purchased a Herelink Controller from GetFPV and had it working perfectly. Then, I decided to do a firmware update. I had received a 16 digit KEY from GetFPV and entered that code only to be given an error saying “Cannot Register Your Device”. I got a hold of GetFPV and received a new 16 digit KEY. I tried that KEY only to be given the same error.
I re-downloaded the firmware, re-uploaded it to the controller, tried both the KEYs I was given, and still had the “Cannot Register Your Device” error. I was told by GetFPV that they talked to Herelink and suggested I post the issue here. I am wondering if anyone else has had this issue or knows anything I can try?


I bought mine from GetFPV and the key they gave me was good. More than likely you will be asked to contact someone here.

We contacted a representative from GetFPV who gave us a couple of different keys to try but none of them seemed to work and so we were asked to post in this forum, so we did.

Do you know who to contact here regarding this?

Try a diferent internet connection at the point of activation and download . Something like your tethered phone or anther Wifi at the time of activation.

You can get this issue if the connection is not good when trying to activate.

We have seen other users post similar issues.

1 Like

Thank you @MadRC. We tried on a different internet connection and the registration was successful.

This issue is NOT solved. Has anyone been able to find a root cause? This is not an 802.11g/n mixed mode problem.

It’s driven by a few things.

Make sure your time and time zone are correct.

Regional settings are also correct then try a WiFi with an IP range outside of 192.168. However to be clear I have updated all my systems on one with that very range with out issue.

Also disable any port blocking or forwarding on your router.

Thanks Mad. I moved from 192.168.0.x to 192.168.1.x and that seemed to work. This is clearly a bug and creates a tremendous amount of frustration for new users.

Where can I submit an RFC?