HereLink Disconnected in Flight

I ran the new Herelink stable firmware update this morning.

I was able to perform an initial flight of around 10-15 minutes with no issues. The purpose of the first flight was to perform a new Servo_Auto_Trim since I’d added flaps and may have slightly changed the wing airflow pattern

I then took off for a flight and the ground/air units disconnected not long after takeoff.

I tried every combination of app and controller restarts but nothing seemed to work. It did connect briefly for around 5 seconds but not long enough for me to land or envoke another flight mode.

The battery depleted enough for the plane to safely land while in loiter (which I have set for both lost link and battery failsafe).

Logs are uploading to here:


ok so the first thing we will need is a bugreport from both the air unit and ground unit.
ideally we need to see the logs straight after this has happened. else the logs are overwritten.

how are you powering the air unit as well?
also what serial port is the air unit connected to?

Is the air unit still hot/warm at landing? If so it had lost telemetry connection but it’s still able to controlled, but you thought that it’s lost signal and you didn’t have any control action during rtl and loiter, did you?? I was in that case!
In actualy, you could still control the plane landing safety!

im wondering if there was a power issue that caused a brownout scenario

I had no control at all until after it landed and I rebooted the unit.

Could be a brownout but I never regained control.

Did you try to control the plane in RTH and Loiter mode?

Yes. No communication at all. Never regained it.

This is a smaller test plane so I’m only powering it with the standard Cube power module.

I have spare Mauch components on the bench and will swap over to them if all signs point to this being a brownout.

could you try a power module at 7-12 volt?

i have seen a air unit that wont boot because its in a brownout, and when it gets in this state it may not recovery because the surge in startup current causes one continuous brownout. ie on my lab power supply