Herelink - no connection between sender and receiver

(Rudi Schneeberger) #1

Have the Herelink put into operation, and connected the receiver to the transmitter.
It worked when unpacking and first turn on immediately.

All telemetry data of the cube was also displayed and I was able to change the settings.

After that, I was concerned with the settings of the station, such as wireless LAN, user name, etc. I accidentally came to the button: airplane mode and have changed into the airplane mode.

This lost the connection between transmitter and receiver. I have switched off the airplane mode but the connection was not established anymore.

Have tried many times sender and receiver to pair again, but unfortunately in vain. It can not be connected.

So I made a firmware update, the sender and the receiver.
Even then no connection could be made.

After that I did a reset to factory settings at the transmitter.
Even then no connection could be made.

Now I do not know what to do anymore and ask for help.

Rudi

(Banme RC) #2

After all do leds on the sender light?

#3

@sidbh

(HG) #4

Could this be solved?

My Herelink also always linked instantly. Just yesterday while doing some channel settings and disconnecting, I can not get any connection any more.

Re-Pairing works fine, when I power cycle the ground unit the air unit beeps, LED is green. Everything looks normal. But QGround control of the ground unit shows “Waiting for Vehicle Connection”, no matter what I do.
USB mission planner connection works fine.

When that happened i did not change any relevant configs or wires. It looks like the RF connection is fine, its eiter a mavlink priblem or QGroundControl problem.

Telem1 / serial1_baud is 57, protocols I tried Mavlink1 and Mavlink2. Is Mavlink2 supported by Herelink?

Cube black, Plane

#5

@sidbh, what’s the best method to factory reset?

(HG) #6

I’m still stuck on this.

Can somebody confirm that the air unit works on a baud rate of 57600? Mavlink2?

Otherwise I’ll just wait for the next firmware update and hope for the best.

(HG) #7

Ok, after two days trying all kinds of things something strange happened.:

I was trying to setup an UDP link trying to at least use the groud unit with the PC mission planner.

When I created an UDP link on Port 14551 on the ground unit, i suddenly had vehicle connection again???

Is that correct? I can not remember an UDP connection having been there before when it worked. Or did I somehow delete it accidentially?

Anyways, hope this helps somebody.

And if anybody could bring a bit of light into the UDP connection i would really be interested.

#8

That’s the normal connection :slight_smile: