Herelink not initiating


I tried to install google services, so I could use an app with google maps embedded, but now my new Herelink is not initiating. It keeps in the page where says “herelink”.
I followed this instructions:

I tried to remove the google services using adb, but when I try the remove (or even list) the packages, it says: “Error: Could not access the Package Manager. Is the system running?”. I can shell into it, but pm is not working.

Anyone has an idea of how can I fix it?

By the way, I did not had a chance to try much, but I really liked what I saw. Great work!

Here is my logcat: (11.0 KB)


Following the instruction for update the firmware fixed it (


Hi @emendes

I experienced the same thing trying to install Google Play Services for a custom Android App using Google Maps SDK. I’m currently also doing a firmware update…

Did you manage to find another way to successfully install Google Play Services?

Best regards,


I have the same issue and reflashing is not helping… It’s reinitialising all the time. I need help