HereLink Problems

Good morning people,

Yesterday during a flying test I had some problems that I would like to comment. I sent the drone to fly a mission, and the first problem was the drone not reporting the position moving in real time on the map screen at it should. The second problem was the battery voltage frozen, so I could not really know how much battery I had left. Also when I tried to change the mode to RTL, the drone was just going up to the predefined RTL altitude staying fixed in the air, but not making its way back to home position.

Other problem was with the video feed, sometimes it freezes. Maybe there are new firmware versions that solved these problems already.

Thank you in advance,

Greetings from Texas

Hi Abel, we had few users that reported telemetry latency. I dont know if it is your case, but it seems that the latency increase during the mission. Starting from 0 at the mission start, reaching 3-5 secondes after 15/20 minutes of auto mission (and more for longer ones)
One of our customers discovered that closing the little map window at bottom left of the screen remove the latency.
What Herelink firmware version are you using ?

Thanks Julien, fast and helpful as always!

The version that I am using is 2019-04-26, I found this date going to General Tab in the Qgroundcontrol Settings.

The problem that we had is not the same than the one you said, its something different. Also I have realized that the connector of the telemetry wire in the HereLink receiver is a little bit damaged, I am going to solder the wires straight to the board and see if I get rid of this failure.