Herelink strange behavior quad crash

#1

Hello,
During tests flights, very strange event happen. After an auto mission and without remove battery I try a second flight when everything start to go bad. Quad copter starts to spin around and went up to the air without any control. I tried change mode to auto, rtl and alt hold without any luck. The quad crash after some time of flight (when the battery was empty) hopefully with out anybody hurt. I check the log file and I see that the rc (herelink) send the continuous yaw movement and a lot of other commands. Please could you see the log and help me. Is herelink problem or something else?
Thanks in advance

link to download bin file

#2

@sidbh

#3

After some flights tests I manage to reproduce the problem. At start I notice that when I armed the copter its disarm immediately, so I check the joystick and I notice that the all channels was at low position and stuck there despite the move I make to joysticks. When I restart herelink everything working fine again. I make a joystick calibration and after a lot of flights is working fine but I am afraid now and before I arm the copter I always check the joystick. I have already buy and use more that 10 herelink units and it’s the first that have this behaviour. Is it possible to understand if it is a hardware error or software?

2 Likes
#4

That happened to me but on throttle stick only. Actually, didn’t check the others. I could not get it to arm and I checked the channel out and it would not change; therefore, couldn’t arm. Reboot solved the problem but, as these are beta units, I am not putting it into my 16kg octo as the main controller for now

#5

@sidbh