Light Weight Telemetry - no data

Hi. Black Cube on a mini carrier board. Firmware Plane 4.0.9 official.

Trying to use Telemetry2 for Light Weight Telemetry output. So that’s Serial2 - set to 9600 baud (have also tried 1200, 2400), and protocol to 25.

Analyzing the second pin (the pin beside VCC) - which should be Serial2 Tx - and I see nothing.

I have used Light Weight Telemetry on other boards (eg OmniBus F4) no issue.

Any ideas? Thank you!

Have you set the Serial2_protocol correctly?

Hi Alvin

Yes - not much to set up really - I happen to use the LTM data at a baud rate of 9600, so that is set to 9, and the protocol is 25 (LTM). This is on Serial2 = Telemetry2, and there is no data coming out the transmit pin (the pin beside VCC on this connector).

I am using LTM on an OmniBus F4 board, and it works fine…

Can you try if it works on telem1 port?

Hi Alvin

I have tried LTM on Telemetry1 (serial1), Telemetry2 (serial2), and GPS2 (serial4).

I can run for example MavLink on Telemetry1 no issue. Just not LTM.

It simply seems LTM is not working on the Cube?

BTW, I am aware only the first instance of LTM is active, so I have been careful to only ever have one instance of protocol 25 (LTM) selected.

Any other ideas appreciated. Is this something you could quickly test?

Ok, although protocol 25 (LTM) is listed and selectable, apparently it is not included in the 4.0.x firmware releases for the Cube.

I loaded 4.1.0 dev from today, and it is working.

Thanks for your help