No telemetry on Herelink

I’m having trouble getting mavlink telemetry working on my herelink. It was a batch 1 device, with the 0.2.2 firmware installed. HDMI video and RC control work properly, but QGC always says waiting for connection.

I can’t figure out why it isn’t working. I checked the cabling, swapped tx/rx, tried multiple different params
serial1 - mavlink1, baud 57600; mavlink1, baud 115200; mavlink2, baud 57600; mavlink2, baud 115200.

I also tried Copter 3.6.9 and 3.7-dev on a cube black.

Is there anything else I am missing?

This is my experience.
First i had a normal connection ( video,RC and Telemetry (57600) ). But after a while, Telemetry didn’t work. I inspected with help of an electronic guy by a logic analyzer. He found that serial port baud rate has changed to the maximum option( I can’t remember the the number now) !

So what was the final out-come? did you get it resolved? I am having the same problem on one of my Herelinks.


In my case, because i used a custom board for telemetry ( not pixhawk or etc) , so i changed my baud rate and problem resolved. I don’t know if it’s possible in autopilot boards or not.

@AI_Seeker hi even I am trying to use herelink for a similar application (i.e. without pixhawk/cubeblack) could you have a look at this issue.