Orange cube: Need Help Please, failure to fully load prams in mission planner


I am running the most recent version of mission planner and have loaded the most recent version of the orange cube firmware. When I try to connect my orange cube to mission planner not all of the prams are loading successfully . The message block will either freeze during the course of loading the prams or I will get a time out message. Also when the prams do load I am getting error messages while trying to save prams changes.

Any suggestions on how I can resolve these issues? I have tried uninstalling and reinstalling mission planner and I’ve also updated the orange cube firmware.


Check your USB cable. What baud rate are you using?

USB cable seems to be fine but I will swap out for another. Rate is 57600.

What baud rate you setting too?

Are you seeing both comports in Mission planner ?

Have you tried the Beta version not the current stable release, you get that from the bottom of the help screen in MP.

Thank you for the advice. I upgraded the firmware to beta and now everything seems back to normal. Hopefully. Thank you again.


1 Like