Pixhawk cube orange, config error reboot

we are able to connect our pixhawk orange cube to mission planner but it is giving an error
config error then reboot and in the logs it is board validation check imu1 present.
please help us in solving the error

image

this error is coming in ardupilot…

when I upload PX4 there’s another error naming MAG0 error.

its connecting to mission planner but no further things can be done its showing only one error to reboot.

May I know the firmware version and frame type did you use ?

Did you try reset all parameter ?

Can you please take a video fo your mp after you connected (with ardupilot)?

Can you get any IMU data,such as acc mag and gyro?

Did you try to re-calibrate this unit ?

Ardupilot firmware
same error even after reseting
no imu data is seen in ardupilot
tried to recalibarate its showing can not send data to cube,…
and one more thing i tried to upload PX4 firmware … in this no error as config data…
IMU data can be viewed but only one error mag0 not found

I’m having a similar issue that I’ve been spinning my wheels trying to figure out. First I lost the drivers for my Cube Orange and my PC wouldn’t even detect the FC being plugged in via USB.So I cleared the drivers in Mission Planner and re-installed and then I was finally able to see the FC and connect in Mission Planner. But I keep getting a the message “Config Error: failed to update IO firmware” and “Fix prpblem and reboot”. I tried re-flashing the firmware and there are several different Cube Orange hardware and firmware options to choose from. And the firmware install either doesn’t complete and detect the board after flashing, or it does complete but continues giving the same Config Error messages as stated before. I’m really just trying to figure out if it’s a software/firmware issue, or hardware failure, or if I’m just missing something. And I’m lost at this point.

Hi Good day
Im facing similar issue


with my cube orange +, any idea what might be the issue?

i had the same with the Cube Orange+,
i tried to change firmware, reset all parameters, nothing solved.
image

I have the same problem. I suspect the firmware. Same cube Orange worked fine before the update. 1st time I have ever seen this…

I have got the same error. The system worked fine a day ago, booted it up today and the ardupilot is stuck in this loop.

I have attached both the mission planner and mavros messages.
I tried resetting the params and changing rover firmware (ArduRover V4.2.3 to V4.1.0) the upload was successful but same error. Also with copter firmware (latest stable).
No IMU feedback on mission planner.

Is there a way to omit the IMU2 out all together? In my operation i use dont use the IMUs anyway, only gps, compass and visual slam.

Screenshot 2023-07-23 133410
Screenshot 2023-07-23 133356

HI
you could cheke (BRD_IO_ENABLE) parametr and chenge value to (0) then reboot and plug out micro USB

1 Like

Whenever Board Validation error like CHECK_IMUx_PRESENT or CHECK_BAROx_PRESENT shows up that generally means that Firmware has failed to detect those chips. There can be two reasons, the sensor has broken or firmware has been unable to detect it. To verify its not the firmware, start by loading the latest stable, if that doesn’t resolve the issue load the latest beta, if even after that the issue persists, as a final test you need to load latest DEV release. To do so in mission planner select All options in Firmware update window and then select DEV from the list of releases.

If the error shows up on all three releases (Stable, Beta and Dev) please report it here or to your reseller. It might be that there is physically an issue with the hardware or we have an issue to resolve in firmware.

I had the same issue. The problem is related to the firmware and the CUBE itself.

Previously we have received the CUBE Orange PLUS with bright orange paint (on the CUBE) ant it was working great with Arduplane 4.3.1
Now we have received the new batch with slightly different paint (more metallic and darker, but still orange with the same logo “Cube+” but with 4.3.1 it gives this error $CHECK_IMU1_PRESENT
But when I uploading 4.4.0 then everything works great. Any firmware below 4.4.0 - not working.

Looks like manufacturer have changed the chips inside without changes in branding (like it was with Cube-Cube PLUS transition)

1 Like

@sidbh any updates on issue mentioned by @Kyryll_Surkov. I am facing the similar issue. The Cube Orange Plus I received is more metallic in color and does not support any Arducopter firmware below 4.4.0. I have tried uploading 4.3.3 and in HW_ID panel the DEVtype for all gyro comes as 59 and not the specific name as used to show conventionally. The config error keep on flashing for version below 4.4.0.

@Un_manned_0102 @Kyryll_Surkov CubeOrange is the version you need if you want to run Ardupilot below version 4.4.0. We post our engineering changes here ENGINEERING CHANGE NOTICE - Cubepilot . CubeOrangePlus current and previous editions have been maintained to operate from version 4.4 and onwards including the latest 4.4 stable.


I too have cube orange+, metallic orange. Once I upload any version from 4.4.0 to 4.4.4, I am still getting the same error of 'Config error: fix problem then reboot". Tried all the solutions mentioned in the discussion. And also, I observed that the gimbal setup is greyed out and cannot set any values(pic attached). Kindly help. @philip @Mike_ZY @rmackay9

First, update mission planner.
Second, start with clean parameters…

Look at the messages tab and tell us all the messages.

@Rishabh_Kashi,

MP’s camera gimbal screen has unfortunately fallen behind the AP flight code’s changes for cameras and gimbals so it can’t be used. AP’s wiki lists the specific parameters that should be set though so hopefully you can accomplish the same thing by directly updating parameters.

I found the answer in another thread. Rolling back to earlier firmware 4.0.7 fixed the “Config error: fix problem then reboot”