[solved]AK09916: cannot reset

(Cornel Fudulu) #1

I get an error (AK09916 cannot reset) under MP - also reported as critical via Yaapu telemetry on my RC - that I cannot get rid of.
Have tried multiple approaches so far: went to Rover and back to Copter 3.6.11, to Plane and back to Copter, to Copter 4.0.0-dev and back to 3.6.11 and it’s still registering.
Also, compass calibration with external mag from Here2 doesn’t work. It only finishes when Compass1 is “not used”

#2

It’s informative only, not an error, ignore it

(Cornel Fudulu) #3

It’s not that easy to ignore.

There’s a $5k Flir on a $1.5k Gremsy gimbal hanging underneath. And each pair of props alone cost as much as the FC itself. Can’t lift that in the air as long as compass calibration rejects any external unit (tried three Here2s) and the internal compass “informs” me there’s a problem.

#4

Your compass calibration issue is the real concern…

In situations like this, start from the beginning…

Load plane, then copter… then only load the additional parameters you need to get flight…

Then try again.

Are you updating the Here2 correctly? Are you running CAN or Serial?
If you are running CAN, it would be Mag3

(Ian ) #5

As Philip said if using CAN it’s going to default it to Mag 3 As it stacks them after the internal ones on Can , it’s an annoyance but You will need to setup mags manually with CAN .

ideally you may want to disable the internal compass at this point to get it to main to default to mag1 however you can also just manually set it as primary in the prams but of the internal are getting lots of interference you may need to disable them totally.

It’s not super simple but there is info on this on true below threads

http://ardupilot.org/copter/docs/common-compass-setup-advanced.html#common-compass-setup-advanced

How to disable

Also this sounds a really nice build would love to see some pics.

(Cornel Fudulu) #6

OK. Found a solution and the source of my problems.

Loading Plane 3.9.11 and going thru accel and compass calibration got rid of any error. Then back to Copter 3.6.11 and everything is working as it should. Calibration works without a hitch, The Here2 is in Serial+I2C mode - I’ve never tried a CAN setup because I don’t have any other status led.
As for the source of the compass calibration failing, the FLIR Duo has it’s own active GPS antenna, and the amplifier inside is either very noisy or badly shielded, or both. I’ve had to relocate further away from the Here2.

1 Like
(Ian ) #7

FYI you can use the LEDs now with CAN as well.

Glad you got it sorted.

1 Like