Tilt Wheel Difficult to Move

I’ve calibrated my tilt wheel but I have to really dig it in to get the ball to move.

The ball does not move unless I really max it out.

Is this normal?

Same here. Actually hurts to move it

Yup same here.

I haven’t connected it to a gimbal or servo yet to test. Does your gimbal/servo actually move with light inputs?

It only has a very small range of motion

this is my 4th herelink unit. first 3 had an okay scroll wheel. this latest one also doesnt tilt gimbal until it starts to hurt my fingers. ive tried scroll wheel calibration but no different

1 Like

I, for the life of me, cannot figure out why anyone would design it this way. It’s useless for controlled gimbal tilting.

1 Like

The other 3 i have setup work perfectly. slight movement and the gimbal moves. its just this newest that the whole center ,ovement is dead until really pushing hard.

It’s fair to say it’s a somewhat comprised design for the wheel due to the compact nature of the RC and setup in that area. It’s a standard pot internally and if the hardware calibration is not resolving it then it’s possible you have a failure of the pot or the shaft.

The reason is has minutes movement as it’s restricted by the hall gimbal that’s close to it. The design is neat just limiting.

There is no technical reason a nice large external pot and knob can’t be modded and added. It’s on my list to do something with next year.

The throttle has a spring on the right had side, this can be removed, you then remove the LH side bracket and install the washer between the gimbal body and the holder on the right hand side. its not for the faint hearted but can be done fairly easily.

1 Like

Hi Ian,
Can you put pictures of how you opened the herelink?

That’s going to be a video as it’s not as simple as it looks lol.

I’m working on a few things on this. I have some time over Xmas so give me a week and will deliver something for the community on this.


ok Ian, thanks.

Hi Ian,
any update?

1 Like

Sorry I’m running behind on this still as the day job as been crazy. I’m going to get this sorted ASAP. Sorry.

Hi MadRC.
Have you given any more thought to modding a nice large external pot and knob to replace the Herelink wheel? I think this would be welcomed!!

He has already upload the video months ago

Thanks and I have done both mods. He mentioned that he was looking at replacing the wheel with a external Potentiometer. That’s what I was asking about.

I recently bought a HereLink and have the exact same problem. Why has this not been resolved yet?

It´s not hard to realize, that this is a software bug probably with calibration /deadband. If I am on the calibration screen for the hardware wheel, I can see the mv values moving just fine linearly. But after calibration the axis only moves, if I move the hardware wheel to the extremes, when it already hurts my fingers.
It seems that there is a huge deadband applied to the wheel, which makes the axis only move with the last 30-40 mv.

edit. Also noticed the sbus output of the wheel channnel moves way too far to 874 and 2124.

The software measures the upper and lower boundary of the hardware wheel. If you have tried too hard when calibrating, it would obtain a further range as the end.
You may try to calibrate it without pushing too far, just slightly beyond the range that Herelink would decide the wheel as bad.

I tried that, but if the range is too short, the calibration won´t finish.

But the main problem is the huge deadband, that is applied to the wheel! Could you please provide a firmware, where the deadband is user settable? This would fix the problem.

To demonstrate the problem, here is how it should work:

And here is how it currently works (not exaggerated):