Trouble Hovering with 5lb Payload

I have been having an issue with my quads lately. I dont think I have changed anything on the parameters. I can fly with a 3 pound payload and the quad hovers great. I can move the quad up and stop, and the quad stops. I can move it down and it stays down. However, when I go to a 5 pound payload, when I go up, it continues to climb. I can eventually fight it back to a hover, but it will gradually (0.1mps) fall or ascend. When I go down it wants to continue to go down.

I am using 4.0.7 stable. I have been able to eventually fix it by resetting the parameters multiple times, but It is hard for me to belive that it is the solution. I think I am missing something.

Can someone take a look at the logs and parameter lists?

I have been told there may be an issue with the tune, but not sure how to tune the hover point. The Hover thrust in the CTUN parameters of the logs is staying constant. I Really need some help with this! Thanks!

Motor3/ESCs is consuming extra power in 5lb setup. Not sure why.

It was balanced with motor4/ESC4 in 3lb setup.

The hover throttle in 3lb setup was flat while was raising in 5lb setup. Maybe you just need to fly longer for the copter to learn the hovering throttle under 5lb payload.

Im sure the imbalance was from the 3lb payload (just sandbags) vs the 5lb payload which is a camera and gimbal.

I have tried to fly for longer. I thought I had the issue fixed as it seemed like I could wipe and reflash the firmware every over and over and it would evenutally fix itself. I have done this with 5 or so units.

I was able to get one to hover with a payload while on 4.0.7 and flew great. with the 5 pound payload

the hover thrust adjusted like I was use to seeing

then i got greedy and upgraded the firmware to 4.1.5.

I flew without a payload. It seemed to hover fine, but the hover thrust is stuck and will not adjust

I am sure that this COULD be a coincidence, but it seems to be an issue with the firmware? Sometimes it works and sometimes it doesnt. What are your thoughts about this?

@xfacta @MadRC @Michael_Oborne

Have you ever seen this?

This a huge issue for me. I wonder if it has effected anyone else?

I think the thrust tuning data are saved in parameters, so maybe you can save the param file for each payload setup.

I have tried that. With the large payload, even when the hover thrust line is near the middle, it still rises and falls indefinitely passed where I let off the stick. There should be a constant change throughout the hover thrust and from my experience is never linear. If I wanted it linear I would set the hover value and take the learning off. But that will work for that environment. If I go to a different climate the hover thrust value will change and that value is now junk.

I don’t think this should be an issue, but it certainly is. What scares me the most is there is an obvious lack of firmware checks after the cube is flashed.

Is this a problem? When I set CAN_P1_DRIVER to 1, the green bar at the top loads and then stops and never moves. Although I get the prompt that the parameter was saved successfully.

When the green bar is visable I cannot use any other tab as it says parameters are loading. The only way to fix this is rebooting. I wonder if this is causing my issue.

After wiping the firmware I was able to get the hover thrust to get close to the thrust but became linear after the initial takeoff. It never reached the target altitude.

This has nothing to do with thrust control.
The green bar indicates Mission Planner is reading parameters. So maybe somewhere was stuck.

This looks like a bad throttle PID.

As your copter performed normally in some setup, it seems the hardware is working fine. You may ask this on Ardupilot forum to be more focused on software/tuning aspects.

I finally found the solution. This issue was caused by the Lidar Lite V3 downward facing lidar. After disabling the lidar the drone flew perfectly.

What is weird is this happened even passed the lidar’s max height set in the parameters.

Another weird thing is that why does this only happens with specific payload.

I agree. The hover thrust did not operate correctly due to the rangefinder, but on a 4.3lb payload the drone hovered fine. I think this issue is worth looking into. It seems that the lidar is not being blended into the estimator correclty if disabling the lidar fixed the problem. I have had this issue on all firmware verisions including 4.0.7 and newer.

May be your 5lb payload was blocking the lidar sensor, that makes the drone confuse because the baro moves up and the lidar not. Or may be the sand bags are hanging arround and when the drone moves, the bag move under the sensor. You may want to be sure too your max distance sensor is a distance the sensor can be reliable.