Unable to Pair Herelink Tx RX

Hi everyone!

New to this platform so apologies in advance for any mistakes.
In the radio data section provided in the drop down screen, my herelink is showing:

  1. No signals in “Controller signal Strength: M__ & S__”
  2. Paring : “Unknown”

When I tried paring the devices as per the standard procedure given on docs.cubepilot.org , it shows an error message “Time out and try again”

To rectify this I checked many threads on this platform saying to update the controller and the air unit using the firmware flasher…but the flasher_mac.zip, flasher_win.zip & flasher_linux.zip file downloaded from the link is having some issues as it is not extracting. Tried downloading & extracting several times by several ways but not succeeded yet.

According to me 2 potential errors are identified…one, the flasher file is corrupted & second, the controller signal strength is showing no values… Kindly provide the flasher file through any alternate way…and guide me through the rectification process.

An early response will be highly appreciated.

Thanks.

The issue will be they are not on correct firmware versions.

The flashers work fine ok on both PC and Mac. Usually PC side issues is related to not running with admin rights and not having the correct drivers.

Have you installed the Google Android Tools ?

Yes…having Android studio installed on my Mac… kindly guide me…how can I extract that flasher_mac.zip file…? which driver is required for it? If possible pls share the link of the required driver.

Thanks.

That is an ordinary compressed zip file. You don’t need any special drivers to extract it. The OS default decompressor tool will do.

FYI,
flasher_win.zip 12.9MB
flasher_mac.zip 47.7MB
flasher_linux 180MB
You may check if your download was successful