Unable to setup TF mini lidar

(Aniket Tambavekar) #1

I have attached TF mini to pixhawk cube telem 2 port. Parameters are set according to the autopilot document. The orientation of the lidar is towards front facing.
When i am changing RNGFND_ORIENT=0, then mission planner is showing sonar range as 0. When i am setting back to 25(downword) its showing correct value.
also, With downward position as we have tested its showing the proper range but not able to avoid the obstacle. can you help me with this problm?

@philip

1 Like
#2

I think this one is best asked as an Ardupilot question? @rmackay9?