Wifi, Cannot register the device!

Hi everyone,

Sorry this is bit of a rant post as well.

My company got a herelink last sep and didn’t use it at all, I recently pulled it up because we needed it and flashed the firmware excited to test the new features, but apparently I could not register the device because I need a key which we did not get initially. We got it through Ubuy and there is no reseller information and Ubuy slyly said “support window closed”. Thankfully, we did contact herelink and they provided us a key from IR-Lock, our apparent reseller.

But I literally cannot register the device, because the wifi, even though the connections are good (tried in home and office, over 250 mbps) it barely recognizes a few open connections, does not recognize any connection through mobile hotspot or data or whatever and I have been just been stuck with the controller for the past week staring at the register device window. It’s very frustrating :frowning:

Can someone help me please?

The problem is usually IP address range on the WiFi. You need to avoid anything in 192.168. Usually people find mobile hotspot will get them passed this as mobiles tend to hand out addresses out side of this range.

It can also be something blocking the connection like firewall ect but IP is the usual culprit.

Hi MadRC,

Thank you for the response. The herelink device would not detect any networks including mobile hotspots. I had to perform the following steps:

  1. Switch on mobile data
  2. Switch on mobile hotspot
  3. Connect my laptop to the mobile hotspot
  4. Connect herelink to laptop via USB.
  5. In more network options, I had to select USB tethering.
  6. Log into the network there.
  7. Then it was finally connected to the network and started downloading the update.

Why is this so convoluted? Should I check later if my herelink device has some wifi detection issues?

the wifi has to be 5.8ghz, and you may also need to select the correct region from the very first drop down.

5ghz is the wifi connections that I have tried to connect in actually, but I believe that is the same as 5.8Ghz. Region was set to the supplier location, in our case, IR-Lock, US. But it’s working now, just that I got it through a random sequence of steps.

Hi @Gowtham,
How do you “6. log into the network here”?

Once you tether herelink and your laptop with the USB, it will show network 2 (connected or not connected) when you click on the wifi/ internet connectivity icon on your taskbar (Like the image below).

Now, on herelink, you can choose any wifi/ network that’s available on your device and in my case, since my office wifi had a log in portal after connecting to wifi, I had to log in with my details.

To be honest, it was a random sequence of steps which I did so that I can try connecting to herelink with my mobile data through hotspot.

Hope, this helps!