Yellow Cube Firmware Issue

Hello,

I’m having an issue with my yellow cube.

I had this cube running great with the 3.7 DEV firmware. When I installed the latest stable (3.6.10) firmware, I get “Initializing APM” popping up over and over again in the message window and “NO GPS” in the flight deck display. It also won’t calibrate accels nor compass. I’ve tried a few things already:

  • Fresh MP download
  • Reset the board using EEPROM
  • Switched firmware back to 3.7 DEV then to 3.6.10 again
  • Multiple boards

I’ve had this exact problem with all 4 of the yellow cubes I have.

If you have any feedback/ideas for anything else to try I’d appreciate your input.

Thanks!

-Ben

Can you set logging while disarmed and post a log?

So I set logging while disarmed to get a log, and now I have a new problem :roll_eyes:

I get an error when trying to load the log files. I set “Reset to Defaults” on all params, and still have the issue.

image

The Yellow is beta, all real support will be on 3.7, so best to use that, keeping in mind that 3.7 is changing daily and not stable

OK, thanks for the reply. I appreciate your time.

However, do you know why I’m getting the error above?

That’s with 3.7?

No, 3.6.10. I’m going to switch back to 3.7 but I’m just trying to get a log for you guys.

The reason I want to use 3.6.10 is to be able to compare it one-for-one with a black cube, using basically the same firmware.

Then use 3.7 on the black… (actually it’s 4.0…)

No use trying to compare a tried and true stable product with a beta on the wrong firmware.