Herelink fail to update


I got the product key but when I enter it says “cannot register your devise”!!

Also flashing the firmware always fails, I tried with Linux, windows 10 & MAC nothing succeeded!

Please help

I tried to update USB drivers but it didn’t work!

please enable developer mode, and sub debugging
reboot the unit, while holding down the D button, to enter fastboot mode, and then try

I am doing so by pressing power & D buttons to initiate fastboot is that what you refer to?

How to enable developer mode and debugging?

I did the changes you advised still the firmware update fails due to USB issue.

I managed to update the herelink using the product key and all seem to run perfectly. Do I need to do the firmware update? Is it safe to fly with UAV without firmware update?

The air unit must be updated by flasher unless its firmware is newer than certain version. Otherwise it won’t pair with controller.

For controller unit, you don’t necessarily need flasher if the system updater inside works perfectly.

Hi Alvin,

The herelink firmware flash always fails due to usb issue! The update I referred to is the one made using wifi not the USB one.
The airlink couldn’t be updated since the USB failure still there.

I tried using multiple computers with different OS but no success.

I can say the product is too complicated to setup and that’s a wrong commercial approach. It’s a GCS that should work out of the box and should require minimum effort to setup or even update but currently no one exactly know how to solve the problem even when I shared what messages I got in the terminal.

I agree i bought this product 3 weeks ago & I still cannot fly my drone because I can’t get past these updates. A product that cost this much should not be this difficult… Very dissapponted!
I’m paying a computer tech an extra $200 just to come out & do the driver install & complete the update that’s on top of the $700 that I’ve already paid for the Herelink

Unfortunately we can’t test all possible issues and we relies people to report what they have encountered. Then we solve and share the solution found.

Ordinarily it was easy as plug and update. Such complexity is not a designed feature.

We have noticed the problem and no longer using USB to update in future. Newer batches don’t need the USB update process.

And what should we do with our herelink now?

Buy another and throw this away?

Please try again flashing the AIRUNIT via USB on a Windows computer.

But first install the Google Driver manually as follows:

Hi seven,

I also believe It’s a missing driver but I did installed the driver and went to computer management and picked Optimus and updated the devise using the USB driver file but it didn’t accept it. Maybe it needs special way to work with these drivers

Hm. Did you install exactly this driver?:

I had to do it manually as Windows always said the driver was up to date, but it was not the correct one.

I used the freeware tool „DriverStoreManager“ for driver installation. Immediately worked then.

I understand that you managed to update the ground unit via WiFi. So you only need to update the air unit, right?

Sorry. „DriverStoreExplorer“ (not …Manager)

Hi sven,

You are the only one who gave me a logical answer so far I really appreciate your reply.

Yes the the Herelink was updated using the product key through wifi but airlink still not flashed.

I will try your method and update you ASAP.

So I just use the driver manager explorer to install the driver and that should work right?

Yes. I downloaded the freeware from here:

Hi Sven,

Really grateful to your support and I can tell your advise worked 100%.

You are our Hero here :joy: well done

Please write an article about this process steps for every one to follow that will help the community.

Thanks a lot again

God bless

1 Like

By the way Sven,

Is need to calibrate “Radio” in QGC or herelink joystick calibration is enough?