Pairing Problem

Hi everyone,

recently I bought a herelink kit, ground station and air unit. Unfortunately I don’t get ground station and air unit paired. What did I do?

  • First of all I started the ground station and let it update via WLAN. Pairing did not work (negotiation timed out).
  • Later in the process I downloaded the flasher_win.exe and flashed the air unit with it (don’t know if it succeeded because the window always disappeares instantly). No pairing.
  • Then I flashed ground station and air unit with flasher_win.exe. No pairing.
  • Updated usb-drivers with zadiq. No pairing. Updated drivers with google. No pairing.

My laptop is a Win 10 machine.

Any suggestions?


I would say your bullitpoint 2:

No sucsess, no pairing. So I think you should focus on updating the air unit. I would give it a second chance because of your bullitpoint 4 as last


Hi Bart,

thank you for your reply. I actually gave the Air Unit a second (and third and fourth and so on) try, resetted, the Ground Unit, flashed both Ground and Air Unit … my Latin has come to an end :frowning:


welcome to the land where no one knows this system enough to help you… ive got the solution for you though… you need to plug in the controller to the computer and then download the google usb driver. then under device management you find the controller and uninstall its driver and then manually tell it to install the google usb driver… then you can plug in the air unit and run the flasher again and all will be well.

It fails. You can check the error message by running flasher from cmd or powershell.

As you failed to update your air unit, it won’t pair with the controller because controller has already at latest stable via OTA.

Hi Tyler

are you using windows, make a file on your pc in your C: drive called flasher win,
download the file on too you pc.
drag this file over to your new file in the c: drive.
Right click on the flasher_win file unzip with 7. zip or winzip.
if this is done, do not open the file wait.
plug in our usb cable in the herelink radio press power and D swicth it will go into fastboot plug the usb cable in your pc and opening the flasher hopeful the flashing will start also do the same with the air unit.
after all of this you will be able to pair the two

Yup this is the fix I solved it a few weeks ago

Hi Tyler, thank you for the hint. I tried it but Win10 refuses to let me change the driver; It says to me - also after deinstallation - “The best driver is already installed - USB-MTP-Gerät”.
Kind regards

Hi Alvin,

indeed it failed (Air unit). I started the flasher in CMD and by this was able to see the error message:

Looking for Device…Traceback (most recent call last):
File “”, line 260, in
File “”, line 142, in detect_until_found
File “”, line 241, in detect_unit
File “site-packages\adb-1.3.0-py3.8.egg\adb\”, line 255, in ConnectDevice
File “site-packages\adb-1.3.0-py3.8.egg\adb\”, line 221, in FindAndOpen
File “site-packages\adb-1.3.0-py3.8.egg\adb\”, line 117, in Open
File “site-packages\”, line 2168, in open
File “site-packages\”, line 133, in mayRaiseUSBError
File “site-packages\”, line 125, in raiseUSBError
usb1.USBErrorNotSupported: LIBUSB_ERROR_NOT_SUPPORTED [-12]
[27728] Failed to execute script flasher

I have the other problem that Windows10 refuses to install the google driver with the message: “best driver is already installed: MTP-USB-Gerät”, also if I deinstalled the portable device before. I didn’t find the option “deinstall drivers too”.

You have to click update driver and then “browse my computer for drivers” if that don’t work then right click it then click uninstall device then go from there. But that’s what you gotta do you gotta get the google usb driver to work in order for the flasher program to update the air unit.

1 Like

Hi @aj265

What worked for me was using the „DriverStoreExplorer“ tool (it is freeware, you‘ll find it via google).

Long time ago I did it, but if I remember well, I just installed the Google Android USB driver (link in the Herelink docs section) with that tool and it worked then immediately.

(Like you I experienced that the Windows 10 device Manager did not let me deinstall the initial driver or install another driver.)

You may give it a try.

1 Like

Hi Sven,

this worked, flashing was successful and pairing afterwards was no more problem. Thanks for that fix!

Issue resolved!


1 Like

Hi Tyler,

at the end I had to overcome the aversion of Win10, to let me install that driver. Using “DriverStoreExplorer” (below) helped in the end. But many thanks for the initial hint for it showed me the way to go!


1 Like