2.1 Cube won't arm


I have a 2.1 Cube mounted in a quadplane and have been hovering it around, tuning some, in prep for the wings and horizontal flight.

Two days ago, I installed the wings and find the cube won’t arm. I turned off all prearm checks with the same result. My OSD posts system status messages and what keeps popping up is “Z_Altitude” either unhealthy or OFF.

I flashed Copter, then back to Plane and used my saved settings. Still no arm. Flashed again and did not use the saved settings and stepped through the whole Arduplane setup wizard. Same result.

Google is telling me I might possibly have a bad baro in the Cube.

All of my Black Cubes were purchased prior to the service bulletin issue.

Has anyone else run into this?


Can you post your pram file.


As a new user, the site won’t let me upload attachments.

If you’re game, PM me and I’ll email them.


Turn the prearm checks back on to start with, then look at the messages tab in mission planner and try to arm, put a screenshot of that here :slight_smile:


Must be the site, since I tried to upload my param file earlier and the site wouldn’t let me.

Attached is the screengrab of the messages. I’ll post a separate message with the OSD system status page, which are Mavlink messages, in another post due to being a new user here.

As you can see and I have no explanation why, the Mavlink message of “Z_Altitude” unhealthy/OFF is OK now. I am also able to arm with the Taranis sticks, which I could not do before.

It’s a bit frustrating to confront a problem, troubleshoot and research it, disassemble the gear, re-assemble it and it works now and don’t know why?


Mavlink system status page.GRABS00002

next time if it happens, look at the messages tab straight away