Accel Calibration Failed - IMU problems

Hi guys,
Have a nice day!

I am setup cube orange and Here 3 GPS. But I have a little problem with the cube, I can’t ACCEL Calibration. I tried many times with 4.0.7 copter stable firmware but failed. ( it also fails with older stable firmware)

I realized that the IMU sensor seems to be not good. IMU2 az2 has a high value (-15999) and does not change when Pixhawk moves.

I also tried disabling IMU 2 (INS_USE2 = 0) and setting EK2_IMU_MASK = 5. But still no success.

If I set INS_ENABLE_MASK = 5 to disable IMU2, Pixhawk shows error Check BRD_TYPE: INS: unable to initialise driver, but I am sure BRD_TYPE = 3.

( same result if i disable both IMU 1 and 2 or 2 and 3)

I have attached log file.
Log_bitmask=655358 Full IMU
Log_bitmask( Default)
Could you help or give me advice?



Are you installing the correct firmware for cube Orange ? It must be the Orange build.

@MadRC Thank for your advice, but I sure about Cube Orange Firmware

I have same exact error with same exact axis i also tried to disable second imu and got the “Check BRD_TYPE: INS: unable to initialise driver” error

Firmware is correct for cube orange and tried 4.0.3 - 4.0.7 and 4.1

@Thanhtrinh Hi! Did you resolve this issue? Have the same az2 -15999
on px4 got message ACC1 clipping, not safe to fly

Hi everyone, we are experiencing the same problem. The second IMU x-axis acceleration is fixed at -15999. I shared the flight logs below. Please don’t mind the bad tune or lack of a notch filter. We are working on it.

in general apart from what looks to be a rought landing/takeoff i dont see any issues with these logs?

are you use your telem link was wokring ok?

Hi Michael,

This vehicle was 3D accel calibrated. You can see the IMU2 Accx value was zero all the time and the INS_ACC2OFFS_X value was -156.8922.

Do you think this is a driver problem or hardware problem? Either way, it will be safer to disable this IMU.