Accessing debug port on bricked cube black

(Duncan) #1

two months ago I built a large fixed wing UAV with a brand new cube in it. All setup, taxi tests complete everything checked out ok. Probably has 3 hours bench run time and 30 mins taxi testing.

Stored the aircraft in its case and this morning got it out, powered it up and the cube will not boot. Red light on carrier flashes and then goes solid but will go no further.

Have tried every trick under the sun and no results. This is worrying as it was working perfectly when it went in its box.

Has anyone had success pulling debug information from serial5? If so can anyone give pointers on how to do this? I really need to try and understand what has gone wrong here before I am forced to buy another unit. Its a cost I did not need but also a worry about why this one has seemingly died without reason.

#2

There is no useful debug information on serial 5 anymore,
Can you connect to Mission Planner via the normal USB connector?

What code was running?

(Duncan) #3

Ahh that’s a real shame!

I believe it was 3.6.7 but I can’t check as it won’t boot.

I’ve tried connecting using usb plugged into cube and into the carrier board adapter and no luck. Won’t boot on usb power or main power.

Can’t connect via mission planner and can’t install different firmware.

Cube flashes red and then solid red but doesn’t boot. Buzzer makes quiet hissing sound.

Have tried booting with no peripherals and still no luck.

We’ve flashed a brand new cube and installed it in the aircraft and it’s all working fine.

I’m genuinely worried about what caused this to occur on a pretty much unused cube.

#4

Why are you running 3.6.7? You MUST be on 3.6.10 or later!
Please read the service bulletin!

Ignoring that for a moment…

Please RMA it, which distributor?

(Duncan) #5

As I said, couldn’t remember the firmware number. I installed whatever firmware was current just after the imu switching issue was patched for the first time and enabled all imus as per the service bulletin. This was done during build before the testing mentioned in my previous post.

Aircraft was sat in a box for a few months so not updated recently.

It was from 3dxr in the uk. Will rma it to them.

Is there a. Rma number you’d like stuck on it?

(ben wilkinson) #6

I assume it was more like Plane 3.9.7 ish firmware. If you had removed and wiped the SD card try the below, it worked for me on about the same firmware when i had a similar issue.

Plug in USB and start mission planner, you should still see a com show up. load the latest plane. It should update and save parameters.

Also try removing some serial connections if you have extra GPS and lidars fitted. and get it to update.

I believe there was a bootloader update to address some lockups (Phillip, like on blue where tridge did a fix)

And obviously you can RMA

(Duncan) #7

Thanks Ben,

We did attempt to change firmware and removed peripherals but didn’t get any luck.

I’m on leave next week but will try what you suggest again on my return.

Much appreciated.