Adding Rangefinder Benewake TF02-PRO via I2C?

Hello everyone, I’m a new member of CubePilot and I’m asking myself some questions about the Arducopter environment.

Here is my case:
I want to add the Rangefinder Benewake TF02-PRO to the autopilot environment (Pixhawk Cube black). I already know that I can connect it via Serial Port / TELEM port (it works). However, I found on its Product Manual ( benewake-tf02-pro-lidar-led-rangefinder-ip65-40m-manual_.pdf ( that we can set the I2C protocol as the communication protocol (and I want to test that).

I sent some command via the app “WINCC_TF” to set the I2C protocol.

  • First I entered in the configuration mode via the command: “AA 55 F0 00 01 00 00 02”
  • Then I switched the mode: “5A 05 0A MODE 01” (0 for UART , 1 for I2C), the default adress is in hexadecimal 0x10
  • Finally I closed the configuration mode via: “AA 55 F0 00 00 00 00 02”

On Mission Planner, I changed the RNGFND1 settings:

  • RNGFND1_ADRESS: 16 (0x10 in hexadecimal represents 16 in decimal)
  • RNGFND1_TYPE: 19 (Benewake TF02)

But it doesn’t work at all (no Sonar value). Any suggestions ?

Thank you for you replies :smiley:

I’m not sure if Ardupilot supports TF02-PRO in I2C mode, as I don’t actually see people using it this way.

I can only find people using TF02-PRO in serial mode, or TF-Luna in I2C mode.

1 Like

Thank you for your reply. I’m going to check the related topics above.
But yes, maybe Ardupilot doesn’t support the I2C mode.