Air Unit Firmware Updating Issues

I’m not sure where to start. But my problems sound like several others i’ve read but i’ve found no solution.

I have a Herelink with Two Air Units. Everything had worked fine until I tried updating to the latest update. The Herelink updated no problem however the Air Units are a different story. Like many other posts I see, the main error after executing the update file is “UNABLE TO EXECUTE SCRIPT.”
This has been tried on a Mac, Win7 and Win10 computers. I understand there’s a problem with the ADB driver. When I update the driver manually it doesn’t recognize the downloaded driver from the Cubepilot site. At some point on my Win 7 computer the ADB driver properly installed after plugging in the Air Unit. I don’t know why it worked.
Of course I ran the Flaher_Win file and everything appeared to start updating properly. The file was downloading and the installation began. However the installation stalls as its 34% through the Boot flash.
Flashing Partition: 100%!
Flashing persist: 100%!
Flasing oem: 100%!
Flashing boot: 34%!

It then says there was a Write Failure and unable to execute script. This is where I am stuck. I can reflash it but the same problem persists. Now the LED indicators won’t turn on. I assume because of an incomplete firmware installation.

The Second Air Unit is one step behind. Where the first Air Unit somehow found and installed the correct ADB driver on Win 7, the second Air Unit can’t find the ADB Driver.
What should I do next?

just try again,

and you are powering the air unit with 7v+ ? while doing this?


I usually find a way to make it work but I hate to say I’m out of ideas. So now I have a Herelink that’s been updated to the latest firmware. I have one Air Unit that starts to update but fails and a second air unit that won’t update at all. Neither of them will pair with herelink in their current state. Unless there’s another option to make it work could I mail them into you guys to update them for me?

After uninstalling and reinstalling the drivers several times i finally got the ADB driver installed correctly. I can now make both my air units begin the update process. However they both fail once the Boot flash portion of the install begins. It hangs at 0% like it’s waiting for something and then fails. Any Ideas are appreciated

I’ve switched back to my Mac from the Win 7 computer. I execute the script and it says it failed to execute. It appears to fail when its downloading the package. The URL Grabber says this error:

Looking for Device
Found Unit Type: airunit

Downloading required package…
Traceback (most recent call last):
File “urlgrabber/” , line 1583 in _do_perform
pycurl.error: (77, ‘error setting certificate verify locations: CAfile: /usr/local/etc/openss1@1.1/cert.pem CApath: /usr/local/etc/openss1@1.1/certs’)

Back to the Windows 10 computer. It finally worked! The ADB driver somehow installed itself correctly. I didn’t do anything to make it happen. I just plugged in the Air Unit, looked for it again in the device manager and it said the device is working properly. I ran the flash file and it worked until completion.