Airunit can’t pair

  1. I’ve already updated & re-flash both controller and airunit but I still can’t pair them.
  2. I aslo switch the toggle to 1up 2down or i mix and match them in every possible way but it doesn’t help either.
  3. I also tested it with only one antenna & two antenna but it doesn’t help
  4. It always said Negotiation timed out, please try again.

Please help me with this!!!

Do you mean the toggle in the case?

It should be both down all the time(flash the firmware and pair).

When did you get this unit?

What is your power input?

What is the led indication?


& yes I already put them both down and flash the firmware.

It’s in fall.

The power output is 12V.

The Led indication is Yellow. I press it till it blink to pair.

But it still won’t pair.

I am having the same issue as Morty_Said. Version 1.0 for both parts, LEDs working as expected, air unit is powered by 9 volts. After updating both the air unit and controller I am unable to get them to pair.

I tried doing several reflashes, even tried 2 other air units and have the same issues. Also did a complete reset of the controller.

Is there a utility of some sort I can use to roll back the firmware?

thank you so much. I followed your advice and it is now paired :hugs:

Morty_Said, what was the work around?