ALL Serial modems unable to connect

#1

ENVIRONMENT:
Cube Green latest MP and Firmware
Telem1 port (Serial 1) GND, TX and RX pins only
Serial TTL at Modem TX-RX, RX-TX confirmed
UDP at 14550 send and receive ports both ends
Baud tested at 57600 and 115200 both same result
Modem and MP links established on both APM 2.5, Pixhawk and Emlid at 57 & 115
Also Tested modem as VCP with failed connections
Also Tested modem as UDP Server and Client Modes with failed connections
Also Tested modem as TCP Server and Client Modes on Port 5760 with failed connections.
Modems are linked
Ethernet is tested and verified on Air and Ground

Unable to establish MAVLink
At a Loss …Help would be Great…Software? UART? Firmware?

#2

Additional Details:
SBUS is relayed over modems successfully no issues, Calibrations and modes work perfect

#3

Something is seriously wrong when you can not connect a simple FTDI USB direct to the Telem1 port and get time out with “No Heartbeat Packets Received” error

  1. No it is not the USB cable
  2. Same type connection problems since APM days Hit or miss depending on the Build
  3. Yes Tx to RX and visa versa
  4. Yes it is a certified FTDI chip
  5. SERIAL is SERIAL unless you muck it up in the code
  6. Signal is not inverted…heard that one too!!
  7. Yes, tried the OSD Telemetry button too !!
  8. This is getting old!!!
#4

UDP and TCP are for wifi connections close mp
Reboot computer. Start MP from drop down select auto and see what happens

#5

Modems are Wifi. My modem happens to be in the 900Mhz ISM band. Historically, Past documentation stated to never use “Auto” for connections. I tried your suggestion thinking it may be yet another undocumented procedure…Result: MP Hangs and Crashes…NEXT !!!

#6

Tested with RFD900x modems
Tested with 57600 and 115200 both Fail
Modem Firmware 2.65 configured and tested with RFD Tools
Verified Link within MP with Link confirmed

Hex, ProfiCNC or Michael O you have a Major Problem!!!

This is not my first Rodeo making these links

#7

The problem was Manufacture Issue…Discovered Bad Solder Connection (Cold Shunt) at the Telem1 Tx pin…FYI