Arducopter 4.0.3 - AUX as RC channels problem


I use Pixhawk Cube-orange with Arducopter 4.0.3 frame type: quadro X.
I would like use AUX (1-6) as RC channels (RC9-RC14). In status window
chin9 - chin14 is pwm level 0 despite from Radio is signal 1000-2000us.
How solve this problem??


Change BRD_PWM_COUNT to the total PWM channels you need


Thanks for answer:) I tried it with different number settings ( 4 ,5 ,6,7…14) but still
chin 9-14 is 0 level.

In link below is successful configuration for AUX.

He use Arducopter V 3.3 and has ,1:RCpass Trough" in RC…_Function.
In Arducopter V4.0.3 I don’t have this option in RC…_Option.

Do You have idea how solve it?


The SERVO settings are what you are after.
The RC settings are inputs from the reciever, and SERVO settings are outputs to motors and similar.

For AUX1 output use SERVO9_FUNCTION
To set it to mirror a RC input, set SERVO9_FUNCTION,(51 to 66) to suit your RC input channel.
Setting SERVO9_FUNCTION to value 1 (RC Passthrough) would pass RC channel 9 to servo9 output. RC Passthrough would rarely be used - it’d be better to set the specific RC channel.

If you’ve got some specific function in mind, like Camera tilt, Landing Gear or Sprayer - then better to set that function and let the flight controller operate it under certain conditions, so you dont need to be flicking a switch on your transmitter unnecessarily. Works better in Auto mode for missions too.
You’d obviously also need to set up other associated parameters for that function.


I made settings Servo_9 Function for RCIN 8 and it works but for RCIN9-14 still not.
Why pixhawk don;t see RC9 and RC 10 input from RC receiver?

Are you able to see those rcin channels from the rc calibration in Mission Planner?


I still don’t see RC 9-RC 10. I have Flysky FS-IA10B 10 channel Receiver.

Why pixhawk don;t see RC9 and RC10?


Can you verify that your transmitter is sending on those channels?

Pretty late to post, Thanks Alvin you just clarified if Aux 1 is Servo 9 or Aux 6 is 9!! Will test it.

As for OP, are you sure you’ve connected Reciever via SBus & not Encoder? PPM supports 8 channels but SBus can go till 16