Auto Mode Rover Spinning in Circles

When I setup CubeOrange, in Auto mode, the rover spins in circles.
Did motor test, The “Test Motor C” button only makes the left wheel turn forward. “Test Motor D” only makes the right wheel turn forward.

What is wrong. Rover 4.0


Hi Alvin, thanks for your response.
I check this setting, and tested motor on Motor test in setting page, it works as well.
my question is why Auto mode, spin circles, it does not follow wap_points.
BTW I use Skid Steering.

Another question, I tried to use the full parameter list from CubeBlack to CubeOrange, it looks they are not compatible.

If the rover move normally in manual mode, it could be the PID on steering was not well tuned.
You may check if the autopilot commanded the rover to spin, or it lost control on motors.

Usually this is because you have your motors revered or outputs reversed compared to what the model expects.

So for instance you may have reversed a channel in Herelink or your RC but the FC can’t see that in Auto. You would reverse channels in Ardupilot and not the RC.

If your using skid steer you need to flip the outputs and configure what’s left and right again.