Autopilot without RCIN input

Hi all,
We have an autopilot without RCIN input then we can’t connect sbus signal from herelink air module to the autopilot. I think that the only chance we have Is use the herelink ground module as a joystick to send Stick command on the telemetry (mavlink) Channel.
I saw that QGC (on herelink ground module) don’t recognize the herelink gnd module as a joystick.
I tried to connect the herelink gnd module to another gcs by the USB cable (USB tethering) to use the herelink as a radio only and that solution work but It Is very complex and tedious.

Is there a way to send Stick command on telemetry Channel (without sbus) ?

Is It possible to purchase only the radio module inside the herelink gnd module to use It with another gcs ?



May I ask what autopilot (flight control) you use?
You said your autopilot without RCIN input, so I think the best way is to fix the RCIN. Otherwise it will make the whole process become quite complex.

You can use your herelink controller as a radio and send mavlink from GCS to your airunit ,then you will be able to control your drone without sbus.
(still have to connect your controller to pc)

Best regards,

Hi Mike,
We have a uAvionix George 3 autopilot that inside have a cube Orange as you know.
The problema Is that the carrier board of the George 3 don’t has the RCIN input.

I saw on the ardupolot site that Is possible to change the protocol of any serial port to RCIN and use the serial port RX pin to read sbus signal. I try to se setup the serial 2 port in this way but without success.
Can you help me to do this setup or send me a procedure to do that please ?

This Is the link to ardupilot site:



I tried and it works for me.

I use cube orange and ads-b carrier board.
Futaba t14sg as main controlled(connect to RCIN) and Herelink as second controller(connect to Telem 1,RX and GND only).

And changed serialx_option and rc_options.

Can you double check your pin definition?

Best regards,

Hi @Mike_ZY,

I am from the same team of Riccardo, I would ask you if you can send the parameters setup that you used for your working configuration. Because we are following this guide, but we are not sure that inversion operation is setted up correcly. We are working with a Cube Orange and ads-b carrier like you and its seems strange that it doesn’t working.

Thanks in advance for your time.

Hi Massi

This my setup.(Make firmware version is ArduPilot 4.0 or above)

FC:cube orange+ads-b carrier board.

1 st controller : Futabet14SG & futaba receiver(to RCIN)

2 nd controller:Herelink controller and airunit(to Telem1)

Then I made a special cable for airunit rcout,

1、Get a JST-GH 1.25 mm (6-pin) connector(for telem 1 or 2 ),

2、check ads-b board pin definition for telem port,and find RX and GND(pin 3 and 6)

3、connect RX end to airunit sbus signal ,GND end to GND(use airunit sbus 1)

Then set 2 parameters

4、set SERIALx_OPTIONS to 23 which for RCIN (if you connect to telem 1 set SERIAL1_OPTIONS , telem2 for SERIAL2_OPTIONS since you are using ornage cube+ ads-b carier board)

5、 Set RC_OPTIONS bit to 10( Cube orange use H7 so is able to invert after you set this parameter)

After all this I save the change and powered up my airunit, cube orange and both controller.

1、Use mission planner check rc signal, make sure the sbus signal change when I move joystick on futaba , and no signal for herelink controller even touch the stick .

2、Unplug futaba receiver, and you should see the sbus signal change when you move herelink controller joystick.

This is my set and test procedure,and I hope this will help.