Bad Gyro Health, no movement on artificial horizon

#1

Evening all.

I’m having problems with my brand new Pixhawk 2.1 cube. Bought 2 weeks ago.

Yesterday all was well, I had it on the bench and went through the basic setup, plugged in all servos and crossfire receiver, completed gyro and radio setup and everything was responding as expected.

Today when I installed it into the plane I had issues connecting to Misson planner and my gyro/acc wouldn’t respond. On MP I get bad gyro health message and when I try to calibrate the gyro the MP software freezes up.

I’ve tried rolling back the drivers and even loading rover firmware onto it and then back to 3.9.7 with no luck. I have also tried installing on a different computer and erasing the sd card contents.
The Pixhawk is now back out of the model with nothing else connected, and I still have no gyro info and bad health message.

Has anyone else had this problem and knows a solution?

Many thanks.

UPDATE.

I managed to flash pix4 with Q ground control and the gyro responds, but as soon as I flash arduplane it won’t detect the board.

I also manage to get arducopter working with MP, but when flashed to arduplane it goes back to zero output.

I have seen the bulletin about the gyro issue:
my readings for NS_ACC_ID, INS_ACC2_ID, INS_ACC3_ID, INS_GYR_ID, INS_GYR2_ID and INS_GYR3_ID are all ZERO.

1 Like
#2

Set your BRD_TYPE = 3

Save and reboot. What happens?

#3

Thank you. Something so simple, been tearing my hair out all day over this. I’m new to Pixhawk and Ardu so bare with me.

It seems to be connecting much better now, and the amber flashing has gone out.

The gyro is now responding, and I have calibrated the acc and compass.

I just took a look at my parameters, and although my ACC and GYR ID are now showing the other ID values are off.

1 Like
#4

#5

Any ideas @philip?

I don’t want to test fly this until I know it’s good. Am I right in thinking that 2 of my accelerometers and gyro’s aren’t working?

Thanks.

#6

Did you read this?

1 Like
#7

Yes. I’m on the latest beta mission planner software and have updated to the latest arduplane firmware.
No change.

#8

Updating firmware won’t change anything.
The cube is not to fly until further notice.
Please look at the link for any updates.

#9

Roger