Bad RollWheel

I have 4 herelinks. 3 from beta2 batch and one from beta1 batch (updated to lateste firmware as well).
The RollWheel on all beta2 herelinks works fine. However i cannot get it working on one from beta1 batch.

I tried to calibrate it many times, i tried pushing softer, harder, but no luck. What can i do to make it work?

Is the firmware updated ?

Yes, as you can see display has android buttons on left, which it didn’t have when arrived

contact your re-seller. sorry about that

I have the same issue right out of the box! Cool product, but for the price with issues right out of the box, very disappointing.

Try to pull the wheel harder. When you feel the spring, it is still far from hard boundary. If you are not pulling hard enough, you will miss a lot of ranges from those tighter area.

Hi Alvin,

Thank you for responding so quickly. I did this, and received same results.

The unit was returned this morning back to the distributor for exchange.


Replacement unit works as designed!

1 Like

Sorry about that.