Camera Feed Freezing Every Flight

Hi All!!

I am having an issue with my herelink and cannot seem to find a solution. I am using a pixhawk (2.1) based drone with a gremsy gimbal and a sony a6000 camera. I am also using a third party application that is currently being developed. During flight, the drone is engaged in fully autonomous flight while taking photos on a time interval. After setting the missions parameters, the mission is uploaded to the drone, and it will fly the mission even if the drone loses connection to the herelink controller. It is typically a 20-30 minute mission. I noticed that randomly, the camera feed will start to jump frames until it freezes entirely. The camera feed eventually will unfreeze, but most times it is not until the very end of my flight. The telemetry/drone control is never lost/interrupted at any point. The camera also continues to take photos even when the feed is frozen (verified by checking images on the SD card). Has anyone seen this before? I have no idea what could be causing it. I have tried switching HDMI ports and even canceling the mission and switching to QGC. Not sure if this is related, but on start up I have to go into QGC and switch the stream between 1 and 2 until the feed is displayed. I always close out of the apps before startup (including force stop) and also reboot the herelink controller.

Sounds to me like a loose connetion in the HDMI cable. Have you tested another cable already?
Tried mowing the cable while on the ground?

best regards

I think that is very likely the case. I moved the connection around slightly and sure enough the feed came in and out. Its amazing how we overlook some of the most obvious things when troubleshooting. I had to order some new ones but am receiving them today and hopefully that is the solution.