Cannot connect to Mission Planner using Cube Red

Hi. I’ve just bought Cube Red, and cannot connect to Mission Planner with it.

My old Cube Orange works good on same PC (there are two com ports with corresponding names)
But cube red showing just as USB Serial Device (COM8) and won’t connect or allows to flash firmware. The cube is powered by BEC and connected with proper type c cable (tried another cable - no help)

I tried to reinstall Mission Planner, but it didn’t help.
Do you have any ideas to how fix it?

I found the solution. I’m still not able to flash firmware using Mission Planner, but I did it using qgroundcontrol

How do you flash the firmware? Do you have the other orange cube connected when updating cube red?

Which firmware you using?

Do you select the 115200 baud rate? It looks like 9600 in that screenshot

Does baud rate matter for USB?

The baud rate should not be a problem for flashing, but anyway I tried different options - no luck.

It still says “program extf CRC failed”

No, I connect one cube at a time. I’m trying to flash it the same way as Orange one - connecting to USB, observing that new COM port appears - then go to Setup → Install firmware. I chose official plane firmware, it downloads the firmware, erasing old one, flashing new one (based on the bottom of the screen). But it throws “program extf CRC failed” error.

Plane 4.5.4 official

@Dmitriy_La you can only use Mission Planner to flash the primary firmware. Make sure you are running latest Beta Mission Planner. I don’t think QGroundControl supports external flash flashing yet.

The firmware update mechanism is still fluid, there will be another update to bootloader soon for Primary to simplify firmware update process in latest 4.5 beta, this is the PR waiting for backport, if you want to keep track of progress 4.5 Backport Bootloader Fixes for H7 based devices by bugobliterator · Pull Request #27458 · ArduPilot/ardupilot · GitHub