Can't calibrate my esc

I tried to calibrate my esc using mission planner and following the tutorial, but nothing happen and so I can’t arm my hexacopter manually.
Do you have some suggestions ?

Here is a picture of my setup

EDIT : now Rssi is on the ADC input.
And my esc are on 1 to 6 main out signals.

If you have a safety switch attached try disabling it

I tried to find this, but I don’t know how to do it…

EDIT : I found the way to disable safety switch, it sounds like calibration is working, i hear bips when I throttle up, down then I unplug and then I plug again but I still can’t manage to arm it.

What’s the prearm? Upload a video (2.5 MB)

Here is the video, sorry if the quality isn’t good

Please, I need help

Hey @LaGoiz
To calibrate ESCs,
Push the stick to Max throttle-> connect battery-> disconnect battery and connect again-> Now you’ll hear ESCs double beep-> Push the sticks all the way down-> You’ll hear normal ESC boot sound. Now your escs are calibrated.
You dont have LEDs. You could have been easy with LEDs showing whats happening.
You can’t just arm the vehicle after calibrating ESCs. You need to do complete setup.

@Mallikarjun_SE I already did all of this, that’s why I don’t understand why I can’t arm it now

What’s the Pre-Arm you are getting?

Ok, so I am missing some others calibration I guess, I’ll check
The Pre-Arm is the video I uploaded

Set LOG_DISARMED==1 and share a log or provide video of Messages tab on Mission Planner which doing the process.


I need to disable failsafe ?

I have it when I put FS_THR_ENABLE to Disabled so I guess I can arm it now
EDIT : Okay, it’s working, I just did some mission items and I can arm it now
But I don’t know why my GPS doesn’t work, it is well calibrated :confused:

There’s connection issue with GPS. Its not detected.
I would suggest you to read full setup here and start again.

@Mallikarjun_SE I did compass calibration and it works, I don’t know why it isn’t detected then …
Also I am connected via USB so maybe it doesn’t get enough power ?

EDIT : here is the current EKV when I do nothing on the drone

I soldered the wires of gps to cube, do you think this can be the problem ?

please check you frame class and frame type .

Frame type is X, hexa type. No problem for this