Can't import missions to QGC

Hello everyone,

I am working in a company that uses Herelink a lot with QGC (always stable releases) and we are facing the following problem:

We want to import our Missions files from the QGC of the Herelink controller but we can’t figure out how we can achieve this. We see that there is a relevant section inside the program at: Plan >> File >> Storage >> Open… but it can’t find our mission files. To clarify, I have all our Mission files inside the relevant QGC folder as expected (?)

I can’ replicate this behavior in my laptop since QGC works as expected there. Am I missing something?

I tried on my Herelink. It works fine. Did you put your file in the correct path?
Optimus\Internal shared storage\QGroundControl\Missions

Yes, I double checked this. I also checked if QGC app has access to Herelink’s storage.

Is it in correct format? Or maybe you can try to clear the cache in QGC from App settings.

Hello again,
I tried both but with no success.

You may try to reflash the firmware on Herelink with flasher.