Cant update airunit firmware (windows)

Ground unit updated no problem even on windows7 (which I know is not supported).

Air-unit with windows7.
driver not happy when I plug in airunit - get ADB device with !. Installed SDK and checkbox google drivers. Still same ADB device ! and update fails.

Beg and borrow windows 10 laptop.
After plunging in, driver auto update but message ‘problem with this disk drive’ and it (airunit) showing up under disks as ‘Linus-File-Stor Gadget USB Device’. BUT sometimes shows up as Android device. Either way airunit is found but update gives 'Permissionerror (Errno13) and stops and closes with 'failed to execute script flasher.
Im reluctant to install the Android Studio SDK thing on a laptop thats not mine, which might not fix it anyway.
Any Ideas please.

@Vince try powering up Air unit in bootloader mode. Basically have the flasher program running in detection mode and then power up the air unit while pressing the reset/pair button. If successful the flasher program will detect and update the Air Unit.

Also please note that you can’t have adb server running while you are the flasher program, it conflicts for access. do adb kill-server before trying to run the program.

Tried the boot loader mode. Anyway on the windows 10 machine it does detect the airunit but seems to have a permission problem.

Sorry do t have a clue where to type that adb kill-server. Obviously not run in windows command prompt?

Try running the flasher app as administrator.
It seems you haven’t actually ran an adb command manually, so kill-server is not needed.

After what feels like doing the same thing 50 times today, its just flashed. Cant really say what fixed it.

I had the same issue but finally found a fix.
Open up Device Manager and then plug in the Air Unit. Rather than looking for a USB device or Com Port, look at “Other Devices”.

I found “Android ADB” device just sitting there and you will notice it wont have a driver assigned to it. Download the WIN USB driver that is recommended on the Herelink (Cube) site and extract it.
Update the device with this driver and run the flasher.
It worked for me.

I installed usb zadig , the first winusb, then you can launched the flasher_win