Compass calibration resets after reboot

Hi everyone!

I’m using a Cube Orange with PX4 1.11.0, Here 2 GPS and Qgroundcontrol V4.0. Every time the system reboots (either via software or unplug the power), the compass calibration resets and the heading is inconsistent (pre-flight fail: Compasses inconsistent by x degrees). When recalibrating all sensors (gyro, accel, level horizon and compass) and not click “reboot” it does work fine. However, doing this every time after a reboot shouldn’t be necessary so is there a solution to this problem?

Can you try with ardupilot? Do you get the same issue?

@philip thanks for your reply. With Ardupilot this is not happening. However, the quad will be used with MavSDK to use advanced path planners which is why I use PX4. Ardupilot is not compatible with MavSDK as far as I know. Do you have other suggestions to fix the calibration issue with PX4?

ok, as far as I know MavSDK works with either Ardupilot of PX4, it is all mavlink.

However, if you must use PX4, I would suggest inking this to a PX4 forum, as I am not so good at PX4 :slight_smile:

Alright, clear, thanks

Hello, same problem here,
cube orange and here+ and px4 stable release 1.11.1 and 1.11.2

  • at first i disable the cubeorange internal compass via rc.board_sensors to use only external compass by changing the line “icm20948 -s -b 4 -R 10 -M start” to “icm20948 -s -b 4 -R 10 start”
  • second i build and upload px4 firmware v1.11.1 or v1.11.2
  • third, i do a compass calibration via qgc
    now, the compass works like expected.
  • than i do a reboot
    compass is inconsistent

i post the problem here because on px4 user guide the cube orange is touted as manufacturer supported.

we use cube black for long time in many copters, now we switch to px4 and also cube orange because cube black is marked as deprecated. the manufacturer supported suggests to the customer that the system would work and if there are problems there is someone who at least looks at it. i have since found the problem on all three systems on which i tried to install px4.

please give it a try.

hi @wolke,

Currently I’ve got a gut feeling that sensor calibrations via the Herelink might be the issue.
My QGC app on the Herelink indicates parameters are missing when starting up and that calibrations over wireless connections are not recommended.

Nonetheless, I switched to arducopter however I still got some issues with compass inconsistency because I’ve to replace the Here2 sometimes if I need to check under the bonnet.
No further progress, unfortunately.

Kind regards,

Hi, You may try to change the Rotation degree (like the “x” degrees you mentioned or “360-x”) of the external compass and see whether the problem could be solved. I had ever experienced same problem and solved it through this.